org.nuxeo.ecm.core.api.local.LocalException: No such repository: default after mysql setup

I am getting the following error in the server logs after I set Mysql as the database from the startup setup ui. What could be the issue?

2019-02-27T14:50:00,015 DEBUG [Nuxeo-Work-updateACEStatus-14:196860548906810.1665037896] [org.nuxeo.ecm.core.api.local.LocalSession] Creating CoreSession: default/system#171


2019-02-27T14:50:00,015 ERROR [Nuxeo-Work-updateACEStatus-14:196860548906810.1665037896] [org.nuxeo.ecm.core.work.AbstractWork] Exception during work: UpdateACEStatusWork(, Progress(?%, ?/0), Updating ACE status)


org.nuxeo.ecm.core.api.local.LocalException: No such repository: default


at org.nuxeo.ecm.core.api.local.LocalSession.createSession(LocalSession.java:131) ~[nuxeo-core-10.3.jar:?]


at org.nuxeo.ecm.core.api.local.LocalSession.<init>(LocalSession.java:86) ~[nuxeo-core-10.3.jar:?]


at org.nuxeo.ecm.core.api.CoreSessionServiceImpl.createCoreSession(CoreSessionServiceImpl.java:56) ~[nuxeo-core-10.3.jar:?]


at org.nuxeo.ecm.core.api.CoreInstance.openCoreSession(CoreInstance.java:112) ~[nuxeo-core-api-10.3.jar:?]


at org.nuxeo.ecm.core.api.CoreInstance.openCoreSessionSystem(CoreInstance.java:94) ~[nuxeo-core-api-10.3.jar:?]


at org.nuxeo.ecm.core.work.AbstractWork.openSystemSession(AbstractWork.java:283) [nuxeo-core-event-10.3.jar:?]


at org.nuxeo.ecm.core.security.UpdateACEStatusWork.work(UpdateACEStatusWork.java:72) ~[nuxeo-core-10.3.jar:?]


at org.nuxeo.ecm.core.work.AbstractWork.runWorkWithTransaction(AbstractWork.java:437) [nuxeo-core-event-10.3.jar:?]


at org.nuxeo.ecm.core.work.AbstractWork.run(AbstractWork.java:357) [nuxeo-core-event-10.3.jar:?]


at org.nuxeo.ecm.core.work.WorkHolder.run(WorkHolder.java:57) [nuxeo-core-event-10.3.jar:?]


at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_141]


at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_141]


at java.lang.Thread.run(Thread.java:748) [?:1.8.0_141]


2019-02-27T14:50:00,016 DEBUG [Nuxeo-Work-updateACEStatus-14:196860548906810.1665037896] [org.nuxeo.runtime.transaction.TransactionHelper] Setting transaction as rollback only


2019-02-27T14:50:00,016 DEBUG [Nuxeo-Work-updateACEStatus-14:196860548906810.1665037896] [org.nuxeo.runtime.transaction.TransactionHelper] Cannot commit transaction because it is marked rollback only


2019-02-27T14:50:00,016 DEBUG [Nuxeo-Work-updateACEStatus-14:196860548906810.1665037896] [org.nuxeo.common.logging.SequenceTracer] @@ Nuxeo_Work_updateACEStatus_14_196860548906810.1665037896 -> Nuxeo_Work_updateACEStatus_14_196860548906810.1665037896: tx rollbacking

2019-02-27T14:50:00,016 DEBUG [Nuxeo-Work-updateACEStatus-14:196860548906810.1665037896] [org.nuxeo.common.logging.SequenceTracer] @@ Nuxeo_Work_updateACEStatus_14_196860548906810.1665037896 -> Nuxeo_Work_updateACEStatus_14_196860548906810.1665037896: tx rollbacked 0 ms
0 votes

0 answers

103 views

ANSWER

There must be an earlier error in the logs that explains that it couldn't connect to MySQL.
02/27/2019

Yup! I had 8.0 version of mysql and it didn't had the table mysql.proc because of which nuxeo was not able to create the stored procedures. So, after struggling to find a solution to create that table, I switched to 5.7 version of mysql. That worked!
02/27/2019

FYI this is fixed in Nuxeo 10.10 (LTS 2019), cf https://jira.nuxeo.com/browse/NXP-25622
02/27/2019

Ok! Thanks for the info!
02/27/2019