Default credentials error for first login

Hi, I have installed Nuxeo 8.10 with postgresql 9.6. The installation works fine, but when I try to connect with the Administrator/Administrator credentials, Nuxeo said “Invalid username or password”

Error Log message : ERROR [Nuxeo-Work-updateACEStatus-3:updateACEStatus] [org.nuxeo.ecm.core.work.AbstractWork] Exception during work: UpdateACEStatusWork(, Progress(?%, ?/0), Updating ACE status) java.lang.NullPointerException

    at org.nuxeo.ecm.core.api.local.LocalSession.createSession(LocalSession.java:127)
    at org.nuxeo.ecm.core.api.local.LocalSession.<init>(LocalSession.java:84)
    at org.nuxeo.ecm.core.api.CoreSessionServiceImpl.createCoreSession(CoreSessionServiceImpl.java:43)
    at org.nuxeo.ecm.core.api.CoreInstance.openCoreSession(CoreInstance.java:171)
    at org.nuxeo.ecm.core.api.CoreInstance.openCoreSessionSystem(CoreInstance.java:114)
    at org.nuxeo.ecm.core.work.AbstractWork.openSystemSession(AbstractWork.java:270)
    at org.nuxeo.ecm.core.security.UpdateACEStatusWork.work(UpdateACEStatusWork.java:79)
    at org.nuxeo.ecm.core.work.AbstractWork.runWorkWithTransaction(AbstractWork.java:416)
    at org.nuxeo.ecm.core.work.AbstractWork.runWorkWithTransactionAndCheckExceptions(AbstractWork.java:377)
    at org.nuxeo.ecm.core.work.AbstractWork.run(AbstractWork.java:338)
    at org.nuxeo.ecm.core.work.WorkHolder.run(WorkHolder.java:57)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
    at java.lang.Thread.run(Thread.java:748)

2019-07-02 11:45:00,014 ERROR [Nuxeo-Work-updateACEStatus-3] [org.nuxeo.ecm.core.work.WorkManagerImpl] Uncaught error on thread Nuxeo-Work-updateACEStatus-3 java.lang.NullPointerException

    at org.nuxeo.ecm.core.api.local.LocalSession.createSession(LocalSession.java:127)
    at org.nuxeo.ecm.core.api.local.LocalSession.<init>(LocalSession.java:84)
    at org.nuxeo.ecm.core.api.CoreSessionServiceImpl.createCoreSession(CoreSessionServiceImpl.java:43)
    at org.nuxeo.ecm.core.api.CoreInstance.openCoreSession(CoreInstance.java:171)
    at org.nuxeo.ecm.core.api.CoreInstance.openCoreSessionSystem(CoreInstance.java:114)
    at org.nuxeo.ecm.core.work.AbstractWork.openSystemSession(AbstractWork.java:270)...

Thanks in advance Amel.

FILES:   server.log
0 votes

1 answers

49 views

ANSWER



Hi,

It seems the instance of RepositoryService is null in your case. You should have startup errors or warnings in your logs.

0 votes



Hi,

how can I solve this problem?

thanks for your response.

07/02/2019

As Kevin said, you should see an error when launching nuxeo. Restart it and, before doing anything else, check logs to see the error.
07/05/2019