Publishing rights with users groups

Hello, I am trying to add a canAskForPublish permission to a speficic user group that will manage the publishing of documents. I added a section inside the default section generated by the default configuration section and tried to add that permission there. However when one of the users belonging to my group selects the location to publish the document it keeps saying You do not have permissions to publish under this space. I also tried adding read permissions for the group at the parent and child section, adding the user to members group, blocking out the inherited permissions and adding them as local permissions, but the only way it seems to work is to set everything permissions to the group, which I'm not sure is the right thing to do. Some help would be appreciated.

0 votes

1 answers

40 views

ANSWER



Hello,

If I'm referring to https://doc.nuxeo.com/nxdoc/publishing-content, you need “Read” AND “Can ask for publishing” permissions (this last one is not exposed by default in Web UI, so my guess is that you need to expose it, or modify the default permissions (http://explorer.nuxeo.com/nuxeo/site/distribution/Nuxeo%20Platform%20LTS%202019-10.10/viewExtensionPoint/org.nuxeo.ecm.core.security.SecurityService–permissions).

Regards

1 votes



a c
Thank you for your time. canAskForPublish was actually available and I had it set as well as read permissions. Turns out I only had to change the read to readWrite for it to work!
11/01/2019