I can't start Nuxeo Drive client : Exception: Only one instance of Manager can be create

I installed Nuxeo server from the market place and downloaded Nuxeo client from the admin tab, I even tried the last version from the developement branch. I'm using Nuxeo FT 7.3, Windows 7 64bit. I run the Client msc file and once the setup is done the application is automatically launched, All is good now but once I close it or restart my computer I can't run it again, I double click the .exe but nothing happens. I tried the command line too but in vain.

C:\Users\Lenovo>ndrive
2015-07-13 10:26:39,019 3164 5744 WARNING  nxdrive.utils      qt process with pi
d 816 already running.
2015-07-13 10:26:39,020 3164 5744 WARNING  nxdrive.commandline Qt application al
ready running: exiting
```
C:\Users\Lenovo>ndrive start
2015-07-13 10:34:29,586 4216 6704 ERROR    nxdrive.commandline Error executing '
start': Only one instance of Manager can be create
Traceback (most recent call last):
  File "nuxeo-drive-client\nxdrive\commandline.py", line 496, in handle
  File "nuxeo-drive-client\nxdrive\commandline.py", line 537, in start
  File "nuxeo-drive-client\nxdrive\commandline.py", line 508, in get_manager
  File "nuxeo-drive-client\nxdrive\manager.py", line 196, in __init__
Exception: Only one instance of Manager can be create

It's like an instance of the app is already running, so I tried to kill the process but not working. Any help would be appreciated

0 votes

2 answers

943 views

ANSWER



I found out the problem, if someone has the same issue, a file C:\users\user\.nuxeo-drive\nxdrive_qt.pid must be deleted manually if the app was not shut down properly.

1 votes



This will be fixed in the next release : https://jira.nuxeo.com/browse/NXDRIVE-356

1 votes