Nuxeo drive crashes on mac

Hi,

Today I tried to update Nuxeo Drive to latest revision available on CI (using Github link). Client was unable to start. So I decided to try and reinstall the original client I had downloaded from our Nuxeo instance. Unfortunately it just crashes with very few information. I also tried to restore the .app from Time Machine without any success.

The only log available in console is 19/05/14 14:20:39,382 Nuxeo Drive[415]: Nuxeo Drive Error

Once I've clicked on terminate button in popup window I received the following error message in log: 19/05/14 14:20:50,055 com.apple.launchd.peruser.501[174]: ([0x0-0x55055].org.nuxeo.drive[415]) Exited with code: 255

System : OSX 10.8.5

MBP Retina mi 2012

Edit : Starting it in command line, I have the following message with version 1.3.0416 :

2014-05-19 14:57:00,646 692 140735274721664 INFO     alembic.migration  Context impl SQLiteImpl.
2014-05-19 14:57:00,646 692 140735274721664 INFO     alembic.migration  Will assume non-transactional DDL. Traceback (most recent call last):  
  File "/Applications/Nuxeo Drive.app/Contents/Resources/__boot__.py", line 43, in <module>
_run()  
  File "/Applications/Nuxeo Drive.app/Contents/Resources/__boot__.py", line 38, in _run
exec(compile(source, path, 'exec'), globals(), globals())
  File "/Applications/Nuxeo Drive.app/Contents/Resources/ndrive.py", line 6, in <module>
sys.exit(main())
  File "nxdrive/commandline.pyc", line 520, in main
  File "nxdrive/commandline.pyc", line 318, in handle
  File "nxdrive/controller.pyc", line 189, in __init__
  File "nxdrive/migration.pyc", line 18, in migrate_db
  File "nxdrive/migration.pyc", line 39, in upgrade
  File "nxdrive/migration.pyc", line 82, in run_migration
  File "<string>", line 7, in run_migrations
  File "alembic/environment.pyc", line 652, in run_migrations
  File "alembic/migration.pyc", line 210, in run_migrations
  File "nxdrive/migration.pyc", line 27, in upgrade
  File "alembic/script.pyc", line 179, in _upgrade_revs
  File "alembic/script.pyc", line 161, in _iterate_revisions
  File "alembic/script.pyc", line 104, in get_revision
alembic.util.CommandError: No such revision '511f0b83a413'
2014-05-19 14:57:00.722 Nuxeo Drive[692:707] Nuxeo Drive Error

And this is what I have with latest revision 1.3.0519

2014-05-19 15:20:10,968 838 140735274721664 INFO     nxdrive.controller nxdrive installed in '/Applications/Nuxeo Drive.app/Contents/Resources/lib/python2.7/site-packages.zip/nxdrive'
2014-05-19 15:20:10,968 838 140735274721664 INFO     nxdrive.controller nxdrive configured in '/Users/ange/.nuxeo-drive'
2014-05-19 15:20:10,996 838 140735274721664 INFO     alembic.migration  Context impl SQLiteImpl.
2014-05-19 15:20:10,997 838 140735274721664 INFO     alembic.migration  Will assume non-transactional DDL.
2014-05-19 15:20:11,014 838 140735274721664 WARNING  nxdrive.protocol_handler.darwin Cannot register 'nxdrive' scheme: missing OSX Foundation module
2014-05-19 15:20:12,080 838 140735274721664 ERROR    nxdrive.commandline Error executing 'launch': 'NuxeoDrive.GetClientUpdateInfo' is not a registered operations.
Traceback (most recent call last):
  File "nxdrive/commandline.pyc", line 341, in handle
  File "nxdrive/commandline.pyc", line 355, in launch
  File "nxdrive/gui/application.pyc", line 139, in __init__
  File "nxdrive/gui/application.pyc", line 155, in _refresh_update_status
  File "nxdrive/controller.pyc", line 254, in refresh_update_info
  File "nxdrive/controller.pyc", line 260, in _set_update_info
  File "nxdrive/client/remote_document_client.pyc", line 413, in get_update_info
  File "nxdrive/client/base_automation_client.pyc", line 267, in execute
  File "nxdrive/client/base_automation_client.pyc", line 487, in _check_params
ValueError: 'NuxeoDrive.GetClientUpdateInfo' is not a registered operations.
0 votes

2 answers

1183 views

ANSWER



Actually I think the main issue was from an existing local db in ~/.nuxeo-drive.
When I figured out this hidden file was there, I just erased it and Nuxeo recreated it sucessfully allowing to start again.

1 votes



Hi,

I think the version you downloaded from Jenkins was from the master (~= development) branch, so it is not compatible with your server version. You should:

If you are using Nuxeo 5.9.3, then the client downloaded from the server once the nuxeo-drive marketplace package installed from https://connect.nuxeo.com/nuxeo/site/marketplace/package/nuxeo-drive?version=1.3.3 should do.

If you are using a Nuxeo 5.9.4-SNAPSHOT, then the client must be the one for the master branch downloaded from Jenkins (http://qa.nuxeo.org/jenkins/view/Drive/job/addons_nuxeo-drive-master-dmg/lastSuccessfulBuild/artifact/dist/Nuxeo%20Drive.dmg).

In any case, resetting Nuxeo Drive should do.

Hope this helps!

0 votes