[Drive] Doesn't work on mac : Segmentation fault

Hi, This is a bug report. I dont succeed to launch Nuxeo Drive on MacBook (2008). Nuxeo Drive : 1.2.1218 Mac OS X : 10.7.5 (also tried on 10.6.8)

Double-click on app don't do anything

Error message when trying in command line :

$ ./Nuxeo\ Drive
2013-12-19 16:20:38,782 13853 140735176628576 WARNING  nxdrive.protocol_handler.darwin Cannot register 'nxdrive' scheme: missing OSX Foundation module
Segmentation fault: 11

segfault.log :

$ cat ~/.nuxeo-drive/logs/segfault.log
Fatal Python error: Segmentation fault

Current thread 0x00007fff7635d960:
  File "nxdrive/gui/application.pyc", line 87 in __init__
  File "nxdrive/commandline.pyc", line 348 in launch
  File "nxdrive/commandline.pyc", line 334 in handle
  File "nxdrive/commandline.pyc", line 504 in main
  File "/Applications/Nuxeo Drive.app/Contents/Resources/ndrive.py", line 6 in <module>
  File "/Applications/Nuxeo Drive.app/Contents/Resources/__boot__.py", line 38 in _run
  File "/Applications/Nuxeo Drive.app/Contents/Resources/__boot__.py", line 43 in <module>

Tried to install pyobjc module with pip but doesn't change anything :

sudo pip install pyobjc
0 votes

3 answers

1259 views

ANSWER



Hi,

I recently found out that a Drive package built on OS X 10.8, which is currently the case in our continuous integration chain, might not always work on 10.7.5, causing a segmentation fault at startup. I've tested a build done under OS X 10.7.5 and it works fine. It is available here: http://community.nuxeo.com/static/drive/nuxeo-drive-5.8-2014.0219-osx-10.7.5.dmg

This build is compliant with a Nuxeo 5.8 server with the latest hotfix installed. That might help you in a first place, but for now we are still releasing Drive packages built under OS X 10.8. At some point we might find a solution to distribute a package compliant with earlier versions of OS X such as 10.7.5.

0 votes



Here the system crash report : http://pastebin.com/SBYS2tU6

0 votes



Hi,

Strange, Drive crashing at startup on OS X 10.6.8 with segfault is a known issue: https://jira.nuxeo.com/browse/NXP-13000, but not on 10.7.5. Could you have a look at the system crash report to see if the thread dump is similar to the one attached to NXP-13000?

I Googled “OS X python segmentation fault 11”, only found stuff about OS X 10.9 crashing with Python 2.7.5, fixed in 2.7.6, so I guess not related…

You shouldn't need to install any module as all dependencies (including Qt, PyQt, …) are embedded in the dmg binary package.

Sorry, there is not much more I can tell you for now.

0 votes