Error launching ndrive under Ubuntu 14.04.1 LTS

Hello,

After install all the dependencies for Nuxeo Drive and follow the instructions described in https://github.com/nuxeo/nuxeo-drive/#ubuntudebian-and-other-linux-variants-client, when I launch the command ndrive in the terminal I'm getting the following error.

http://pastebin.com/ugixmyHN

How can I solve it?

Thanks in advance.

Kind regards,

0 votes

1 answers

1043 views

ANSWER



Hi,

Looking at the stack trace it seems that you don't have the latest version of the code. Can you please run:

sudo pip install -U git+https://github.com/nuxeo/nuxeo-drive.git

and try again?

0 votes



Hi, after update to the last version, the stacktrace has been reduced, but I'm getting the same error.

http://pastebin.com/BWHXKmxF

Thanks in advance

02/26/2015

After analyze the stacktrace. I checked the $PYTHON_PATH/dist-packages/nxdrive/nuxeo-drive-client/data, this directory is empty. After copy the files from source to the directory, I can launch the application, but the internationalization doesn't work and the new drive client interface doesn't load correctly.I downloaded the last release of Nuxeo Drive Client for 5.8 from Git and after install, works correctly. At this moment I'm working with this release, https://github.com/nuxeo/nuxeo-drive/tree/release-5.8.0-HF25

Kind regards

02/26/2015

Hi, there was a bug in the Linux packaging, just fixed it, see https://jira.nuxeo.com/browse/NXDRIVE-231. Can you please try the following:

sudo pip uninstall nuxeo-drive

answering yes to all, this is to make sure you will reinstall Drive in a clean directory. Then again:

sudo pip install -U git+https://github.com/nuxeo/nuxeo-drive.git

Tested it on my Ubuntu, should be working fine on yours.

Sorry for the inconvenience.

02/27/2015