Full-text searches with VCS or ElasticSearch

Hello,

I have been trying to set up full-text searches in nuxeo, but I am facing some problems. First of all, from the documentation I have read:

“If you've configured your Nuxeo Platform instance to index full-text using the SQL database (by disabling the default configuration which uses Elasticsearch), Oracle Text needs to be enabled in your database, please consult your Oracle documentation.“ Source: https://doc.nuxeo.com/nxdoc/910/oracle/#oracle-text-full-text

However, in other section I saw that I need to put these lines in the nuxeo.conf in order to enable fulltext: nuxeo.vcs.fulltext.disabled=false nuxeo.vcs.fulltext.search.disabled=false Source: https://doc.nuxeo.com/nxdoc/configuration-parameters-index-nuxeoconf/

But, if I am not wrong, this enables the VCS FullText searches, not the ElasticSearch FullText searches, am I right? But the problem is that, if I set the above properties to “true”, then I get the following error when doing a fulltext query with NXQL (using ecm:fulltext): “Fulltext search disabled by configuration”

Ideally, I want to use fulltext to extract content from binaries (doc, pdf, txt,…) but then, I want to search using ElasticSearch. Is this possible? If yes, how can I do it? I think that, right now, I am using fulltext with database backend (VCS), and this is giving me a lot of problems with Spanish characters (like “ñ” and accents). I have read about configuring Oracle Text and defining a new LEXER, but doing all of this, the fulltext doesn't work as expected.

I am using nuxeo version 9 + Oracle.

Thank you, Rodrigo

0 votes

1 answers

223 views

ANSWER



At the end I have used Elasticsearch NXQL Hints. It seems that, using them, you force the query to use ElasticSearch instead of VCS. More info: https://doc.nuxeo.com/nxdoc/nxql/#elasticsearch-nxql-hints

And to save space, I've also put the nuxeo.vcs.fulltext.search.disabled property to “true” in the nuxeo.conf file.

0 votes