"no start node for graph: blahblah workflow"

Hi,

I'm using the Nuxeo platform 5.9.3 and I currently am on the 30 day trial for Studio.

I have followed the instructions in the documentation to create a simple workflow (http://doc.nuxeo.com/display/public/NXDOC/Simple+Workflow+Example?src=search&src=search), but when I try to apply the workflow on a document, I get the error message I used in the subject line.

Can anyone help me figure this out? Please note I am NOT a programmer, but a user… So I guess if there are any Redditors out there, please ELI5 (for non Redditors.. explain like I'm 5) :)

thanks in advance

Julie

0 votes

4 answers

853 views

ANSWER



Hi Julie,

I'm probably answering too late (sorry), but will still try to give some insight. Let's begin with the missing start node.

When you want to walk, you place one foot after another until you reach your final destination. A workflow is just the same: a succession of tiny steps allowing you to reach a final goal.

In order to reach your destination, you need to start somewhere. Of course if it were you, you would know where you are starting from. But a computer is not so smart. I's actually pretty stupid. You need to tell him everything.

Therefore, when building a workflow, first thing you need to give him is a starting point. That's the purpose of the start node. When you are on the graph tab of your workflow, drag and drop a start node from the left into your whiteboard. Then you can link it to whatever node you like, and the computer will follow these steps in that exact same order. Just remember: whatever you do, this start node is mandatory. And you should have only one (you can have several stop nodes to end the workflow however).

Now a few words about testing your workflow: when you create a workflow and deploy it, it is stored as a template. When you launch your workflow, a copy of this template is made and used to follow the instructions. This means that if you do any modification, you are changing the template, not the copy that is currently in use.

To avoid any kind of error, I would recommend after evey modification to create a new document and to launch the brand new workflow on it. It may seem slow, but it seriously avoids trying to debug things for no actual reason.

0 votes



Hello Bertrand!

Awesome ELI5 answer! :) Thank you!

The solution to my problem however, was simply a piece of information that was missing from the instructions in the http://doc.nuxeo.com/display/public/NXDOC/Simple+Workflow+Example, such info that was probably omitted since it is so obvious to anyone working with this system : You have to update the Nuxeo Software update section of the Update Center…. from the admin section… in order for the changes to be applied.

Once I did that, my workflow was visible. The second error was all mine, once I fixed it, I was able to trigger my workflow and it worked!

So thank you again for your help. I will keep in mind your recommendation to test every version on different documents.

0 votes



never mind… I thought I'd find help here… I have kept working at it and I think I have figured it out.

0 votes



ok… I kept fiddling around, trying to get this to work, I even listened to today's webinar on workflows..

I thought I had found the mistake I had made, but when I tried the workflow again, I came up with this new error message : No route found for id: mydocument.docx

It feels I am so close, but still missing an crucial step.

Please help

0 votes