BUG on workflow Assignees in nuxeo studio

Hello,

I'm stuck on a bug in nuxeo studio interface.

We are using “grouper” convention naming group that is app:appName:groupOfMe

The problem is about workflow in Nuxeo Studio.

You are supposed to use group:nameOfMyGroup for “assignees” on a task. Nevertheless, this field is not cut as it should be. It should, cut “user:” or “group:” and get the other part of the field. But the field is too much cut in the interface and my grouper-based-named is cut by Studio in “app” shortest name and wrong name….

If no “group:” used, it's not a group in nuxeo. If group is used impossible to get the write name with nuxeo studio interpretation. Try to escape the “:” but no way it's always and always cut with this separator…

If i'm not using the “group:” and only “groupName”. Then if the group can see the task, it has no right on it like that : http://answers.nuxeo.com/questions/6026/bug-on-workflow-document-rights

Do you have a solution ?

thanks

0 votes

2 answers

1355 views

ANSWER



Indeed, there is a bug when using as a task assignees a groupname containing “:“, I opened https://jira.nuxeo.com/browse/NXP-11833 to fix it.

1 votes



thanks you very much
06/25/2013

Hello, I installed the 2 patch 20. nevertheless, I still got the problem because in the interface on a task I still read "is assigned to myfirstpartofmygroup" :-(

And the error message is still "User with id 'myid' cannot end this task"

thanks

07/16/2013

Did you try on a new workflow ?
07/17/2013

Yes I started I new workflow document. I saw that in the "worflow tab" it's the good "group name" but in the workflow task it's the wrong one and it's this one that make the exception. thanks
07/17/2013


Hi,

Have you tried using the “Multiple prefixed user/group suggestion” widget type to set assignees? The prefix “group:” or “user:” will be handled in by the widget.

0 votes



Hello, thank you for this answer. The assignee group is still the same so I used the field "assignee" on the task-node of the worflow. I used the group name appName:groupOfMe, because I can't prefix it by "group:". Did I miss something ? thanks
06/24/2013