Edit permission granted by workflow

I'm using Nuxeo IDE 7.10 and i'm trying some examples to discover the default workflow ( Serial / Parrallel document review ) so i'm wondering if the Edit permission granted by Workflow** is sufficient for participants to validate or reject the document , if they originally have no permission on the document.

Actually, i've read here that Participants automatically get Edit permission on the document for the time they have a task to perform on the document, if they had Read permission or no access to the document. but noticed that in Serial review, when the participant have no permission on the document, and when he tried to validate the document, he gets Privilege 'Read' is not granted to 'username' and the document is not displayed anymore on his Dashboard and is considered as validated. However, in Parallel review when the participant don't have any permission he gets the same error and the document still appears in his dashboard.

0 votes

0 answers

814 views

ANSWER