Permission AddChildren needed for create document

Hello,

Recently we have migrate our Nuxeo 5.5 to 10.10 and we have create custom permissions. We have add group associate to this permission on the default-domain's folder with the heritance.

I tried to create a document in a folder under default-domain's folder in the Web UI but i obtain this message : You do not have permissions to create under this location.

When i tried to do this in command line i obtain : {“entity-type”:“exception”,“status”:403,“message”:“Privilege 'AddChildren' is not granted to 'user'“}

This problem arrived on few folder but many works fine. These are all folders created before the migration.

The user has this permissions on the folder:

            <permission name="ReadWriteRemoveUnlock">
                    <include>Read</include>
                    <include>Write</include>
                    <include>Remove</include>
                    <include>Unlock</include>
            </permission>

If i create a new folder next to the other, i can create documents in it. The permissions on this folders are the same. The permissions are herited from the default-domain's folder.

And finally, with a user who has permission “Everything”, he don't have this problem.

So I don't know what to do. The only solution i found is to recreate each folders that have this permission's problem.

0 votes

1 answers

168 views

ANSWER

Hello, can you please indicate if you're using Nuxeo JSF UI of Nuxeo Web UI? Thx
06/08/2020



Hello, i found the solution.

The folders was locked but i've seen that in the JSF UI with the padlock's icon next to the folders. I did'nt see anything in the Web UI that could tell me what these folders were locked.

Thanks

1 votes