Gateway-Timeout Error during upload in Web-UI

When uploading video file >8GB a gateway timeout error occurs after clicking the create button. The browser console shows the following message:;

Failed to load resource: the server responded with a status of 504 (Gateway Time-out) nuxeo-app.html:28198 Batch Execute operation failed: Error: Gateway Time-out

The UI provides the following message:

‚ÄčThese assets could not be created, either because the server could not be reached or some of the assets have problems. You can try to create them again, cancel, or retry later.

When I click cancel the files are correctly stored in the repository storage and the video documents appear in the UI after some time. When I click retry the document is create again (creating duplicates).

Is there a timeout setting to control the gateway timeout?

0 votes

0 answers

158 views

ANSWER

Is there any information in the server.log file related to this? You can configure timeouts in nuxeo.conf, then restart Nuxeo for those changes to be effective. Here are the details for 10.10: https://doc.nuxeo.com/nxdoc/1010/configuration-parameters-index-nuxeoconf/
07/02/2019

Dear Lara,

unfortunately there is no info in the log file.

In older versions of nuxeo there were specific upload handler timeouts:

org.nuxeo.dnd.upload.timeout= org.nuxeo.dnd.exec.timeout=

Are there similar settings for the web ui in current releases?

Thanks

Stefan

07/03/2019

Maybe this one?

nuxeo.server.http.connectionUploadTimeout

Default is 60000ms

Are you using a reverse proxy? Might need to check the max upload settings on that too.

07/03/2019