HTTP and HTTPS reverse-proxy configuration

Hi all,

I'm trying out the Nuxeo community Virtual Machine. To access the repository I have at home I've placed an Apache HTTP server to proxy requests to this and other applications.

I've followed the instructions provided in the Nuxeo Documentation Center namely the ones provided in the HTTP and HTTPS reverse-proxy configuration page.

The problem I'm facing is that when I fill the user and the password the URL changes to something like this: http://192.168.0.40, 192.168.0.40/nuxeo/login.jsp

The IP address is repeated in the with a comma between both addresses. 192.168.0.40 is the IP address of my Apache whereas 192.168.0.55 is the IP address of Nuxeo.

My Apache configuration file has these entries.

ProxyPass /nuxeo http://192.168.0.55/nuxeo
ProxyPassReverse /nuxeo http://192.168.0.55/nuxeo
ProxyPreserveHost On

I've also tried using rewrite rules with the same result.

I have other applications proxied by Apache which don't have this problem.

Has anyone experience this behaviour?

Thanks in advance.

0 votes

1 answers

1777 views

ANSWER



Well, I'll answer my own question. I was connecting to the Ready-to-run Virtual Machine Image. This image already had an Apache doing Reverse Proxy which meant I was doing a reverse proxy of a reverse proxy which led to that mess. Removing the Apache on the Virtual Machine did the trick.

0 votes