Can't preview Word and Excel Documents in Nuxeo 5.6

Hi

First post here, hope anyone can help me, many thanks in advance!

I have installed Nuxeo 5.6 at Debian Squeeze 6.0.7 and I'm having problems to preview Word and Excel documents. Every time I try, get this error:

Preview can not be generated for this document

Technical issue:

Blobpath: default

org.nuxeo.ecm.platform.preview.api.PreviewException: Converter any2pdf is not available**

I have been researching about the problem here (http://answers.nuxeo.com/) and I haven't found a solution :(

First of all, I installed LibreOffice 3.5 following the official guide: link text

After that, I tried modifying jod.office.home=/usr/lib/libreoffice, but still get the same error.

I tried modifying the path to LibreOffice (OOO_HOME=/usr/lib/libreoffice) at /var/lib/nuxeo/server/bin/openofficectl, but still get the same error.

When I look for the error at Nuxeo logs (tail -f /var/log/nuxeo/server.log | grep office)

WARN [org.artofsolving.jodconverter.office.OfficeProcess] Process exited with code 134

WARN [org.artofsolving.jodconverter.office.StreamGobbler] StreamGobbler: terminate called after throwing an instance of 'com::sun::star::uno::RuntimeException'

After these attempts, I reviewed the configuration at the Nuxeo 5.6 Virtual Machine when the configuration I need works perfectly.

I looked for any special configuration at the files:

A. /etc/nuxeo/nuxeo.conf

B. /var/lib/nuxeo/server/nxserver/config/configuration.properties

C. /var/lib/nuxeo/server/bin/openofficectl

D. /var/lib/nuxeo/server/nxserver/config/ooo-manager-config.xml

And all ot them had the default configuration I have in my Nuxeo server, it didn't even use the jod.office.home (for files A and B), or the OOO_HOME variable (for file C), it seems like if the used configuration file is ooo-manager-config.xml, because when I look for a libreoffice process (ps -fea | grep libreoffice) I can see this:

alt text

When is used the 2003 port described as at file D

However at the Virtual Machine I could saw something I consider an error (a bug?), when I stopped the nuxeo daemon (/etc/init.d/nuxeo stop) and started it again (/etc/init.d/nuxeo stop), I couldn't see the libreoffice process anymore and I have the same error I have in my server:

Preview can not be generated for this document Technical issue: Blob path: default org.nuxeo.ecm.platform.preview.api.PreviewException: Converter any2pdf is not available

The libreoffice process just started again when I rebooted the Virtual Machine.

Does anyone knows what is the appropiated configuration I need to do in my environment (Nuxeo 5.6 + Debian Squeeze 6.0.7) in order to preview Word and Excel documents whitout have this error?

Thanks in advance for your help,

0 votes

1 answers

2760 views

ANSWER

Hi,

Do you have install poppler-utils (for pdftohtml)?

We have made our installation on a CentOS server (with OpenOffice) and in our nuxeo.conf, we had a mix between http://answers.nuxeo.com/questions/4797/configuring-preview-with-libreoffice and http://answers.nuxeo.com/questions/4611/automation-conversion-to-pdf-failed-nuxeo-56-cent-os-58-converter-any2pdf-is-not-available

jod.connection.protocol=SOCKET

jod.max.tasks.per.process=200

jod.task.execution.timeout=120000

jod.task.queue.timeout=300000

jod.office.home=/usr/lib64/openoffice.org3/

jod.jpipe.lib.path=/usr/lib64/openoffice.org/ure/lib/

Hope this can help.

Note : "Nuxeo applications come with a daemon that should automatically start it [OpenOffice/LibreOffice]" see http://doc.nuxeo.com/display/ADMINDOC56/Installing+and+setting+up+related+software. So, for me, it is a normal behaviour to see libreoffice process stopping when nuxeo is stopped.

06/03/2013



Hi Manuel.

Thanks for your reply.

Yes, poppler-utils ins installed in my server.

I have solved the problem partially running Nuxeo as root.

nano /etc/init.d/nuxeo

Changing NUXEO_USER=root instead of the default NUXEO_USER=nuxeo

It's a permissions problem at Linux level in my case, I don't know why the nuxeo user can't start the libreoffice daemon, any idea about this?

I tried your solution running the service with the nuxeo user, but I didn't worked, the libreoffice daemon were not started.

Regards,

Raúl Chavarría

0 votes



Hi,

Sorry, I read to fast your post. For me, LibreOffice should not be started with the start of your VM. You can try to kill it and run nuxeo again. I've no more idea.

In our case, OpenOffice is launch by the nuxeo user.

Good luck.

06/04/2013

Running Nuxeo (or any non-essential service for that matter) as root is a VERY BAD IDEA.
06/05/2013

Hi Manuel.

Maybe I wasn't totally clear.

By the Virtual Machine, I mean the Ready-to-run Nuxeo Platform OVF (VirtualBox, RHEV, VMware ESX) (.zip) (http://www.nuxeo.com/en/downloads)

I reviewed it to try to identify and solve the problem in my real server (Nuxeo 5.6 + Debian Squeeze 6.0.7), because it has a similar configuration.

At the virtual machine the preview works well, however the libreoffice don't start when the service is restarted by me (/etc/init.d/nuxeo restart), it just works well when the Nuxeo service is started by the OS when I turn on the Virtual Machine.

A part of this, my problem now is about permissions with the nuxeo Debian user to run the libreoffice daemon every time I start the Nuxeo service, any idea about this?

Thanks,

06/06/2013

Hi Florent.

Totally agree with you, that's why I need to configure the appropiated permissions at Debian level to can run the libreoffice daemon with the nuxeo Debian user, any idea about this?

Regards,

Raúl Chavarría

06/06/2013

In your /etc/init.d/nuxeo, check that you don't have the "-m" option for the "su" lines, on some distributions it was causing problems with the libreoffice startup.
Though openofficectl is still in the distribution, we don't really use it anymore and prefer to let Nuxeo start the daemon itself.
06/06/2013

Hi Mathieu.

Thanks for your answer, now it works well with the nuxeo user :)

I just remove the "-m" option as you said.

Best regards,

Raúl Chavarría

06/10/2013