Word preview not working

Preview is just black screen for a .doc file. Startup server logs indicate : 2015-10-08 16:53:39,151 WARN [Thread-5] [org.nuxeo.ecm.platform.convert.ooomanager.OOoManagerComponent] OpenOffice was not found, JOD Converter won't be available: a process with acceptString 'socket,host=127.0.0.1,port=2003' is already running; pid 19113 2015-10-08 16:53:48,953 INFO [localhost-startStop-1] [org.nuxeo.runtime.osgi.OSGiRuntimeService] Nuxeo Platform Started

When I load the preview, this error appears in the log: 2015-10-08 16:54:39,579 ERROR [http-bio-0.0.0.0-8081-exec-26] [org.nuxeo.ecm.platform.preview.restlet.PreviewRestlet] Could not build preview for missing blob at default org.nuxeo.ecm.platform.preview.api.PreviewException: Converter any2pdf is not available

I've reinstalled libreoffice 4.4 and restarted Nuxeo, and I've made sure the path is correct /usr/bin/libreoffice and /usr/lib/libreoffice (symlinked).

poppler-utils is already the newest version.

Any suggestions?

0 votes

2 answers

2011 views

ANSWER



Usually this problem happens because of the process “soffice”(LibreOffice). Kill it and restart server to get the Preview. Find the attachment to get clear idea.

0 votes



Thanks. Yes, I tried this, I guess more information would be helpful, I have 2 installations running on the same server, need to figure out how to configure the second installation to use port 2004 instead of 2003 (see my other comment below).
10/29/2015


This is because of the process that is running at port 2003 with PID 19113.I suggest you to go the Task Manager and kill the process. Restart the system to get the Preview.

Let me know if this suggetion worked out for you.

0 votes



I think the problem is that I have two nuxeo installations running, one at 8080 and one at 8081. I've set the port to 2004 for the second installation in nuxeo.conf: jod.office.ports=2004. I did try stopping both nuxeo installations (nuxeoctl stop), killing both libreoffice processes (on 2003 and 2004), and then starting both installations again but I'm still unable to convert files to pdf for the preview on either one. I must be missing something in the configuration? Is there more involved for the office ports than this conf setting?
10/29/2015