Nuxeo starting very Slow

Hello, We have upgraded nuxeo to version 9.10. And Nuxeo starting is very slow , about 45 minutes to start ! We think that it provokes by the size of the data ( 145G) because we have a other application Nuxeo in version 9.10 with a smaller size of the data (14G) and it isn't the same problems.Thanks for your helping Regards, Eric Galant

0 votes

2 answers

102 views

ANSWER

I doubt the size of data (files, DB ?) has any effect on starting Nuxeo.

Do you have Elasticsearch configured and reindex on startup set to true ?

What is written into server.log during startup ?

05/03/2018

Yes, we have Elasticsearch configured : elasticsearch.addressList=localhost:9300

elasticsearch.clusterName=nuxeoelasticsearch

elasticsearch.indexNumberOfReplicas=0

elasticsearch.httpEnabled=true

audit.elasticsearch.enabled=true

The log server.log :

2018-05-04 06:14:32,021 INFO [localhost-startStop-1] [javax.enterprise.resource.webcontainer.jsf.application] jsf.core.injection.provider_generic_web_configured

2018-05-04 06:40:54,209 WARN [http-nio-0.0.0.0-8080-exec-12] [com.sun.jersey.spi.inject.Errors] The following warnings have been detected with resource and/or provider classes: WARNING: A HTTP GET method, public java.lang.String org.nuxeo.elasticsearch.http.readonly.Main.searchWithPayload(java.lang.String,java.lang.String,javax.ws.rs.core.UriInfo,javax.ws.rs.core.MultivaluedMap) throws java.io.IOException,org.json.JSONException, should not consume any entity. WARNING: A HTTP GET method, public java.lang.String org.nuxeo.elasticsearch.http.readonly.Main.searchWithPayload(java.lang.String,javax.ws.rs.core.UriInfo,javax.ws.rs.core.MultivaluedMap) throws java.io.IOException,org.json.JSONException, should not consume any entity. WARNING: A HTTP GET method, public java.lang.String org.nuxeo.elasticsearch.http.readonly.Main.searchWithPayload(javax.ws.rs.core.UriInfo,javax.ws.rs.core.MultivaluedMap) throws java.io.IOException,org.json.JSONException, should not consume any entity.

05/04/2018

An embedded ElasticSearch with lots of documents could be a problem
05/04/2018

How I could disabled an embedded ElasticSearch ? Thanks.
05/04/2018

Either set elasticsearch.enabled to false in nuxeo.conf … or setup a cluster

https://doc.nuxeo.com/nxdoc/configuration-parameters-index-nuxeoconf/

05/04/2018



Please check out all the add-ons installed in nuxeo and if they are compatible with each other. You can check the extensions installed using “nuxeoctl mp-list” on windows. In my case, when I installed nuxeo diff add-on and the server never started because it was not having nuxeo jsf ui compatible with nuxeo diff.

0 votes



You can find below the result at the command nuxeoctl mp-list, I don't think there are a conflict between add-on.

Local packages: studio started ubo-ubo-studio-nuxeo-uni-0 (id: ubo-ubo-studio-nuxeo-uni-0-0.0.0-SNAPSHOT) hotfix started nuxeo-9.10-HF01 (id: nuxeo-9.10-HF01-1.0.1) hotfix started nuxeo-9.10-HF02 (id: nuxeo-9.10-HF02-1.0.0) hotfix started nuxeo-9.10-HF03 (id: nuxeo-9.10-HF03-1.0.1) hotfix started nuxeo-9.10-HF04 (id: nuxeo-9.10-HF04-1.1.0) hotfix started nuxeo-9.10-HF05 (id: nuxeo-9.10-HF05-1.1.0) hotfix started nuxeo-9.10-HF06 (id: nuxeo-9.10-HF06-1.1.0) addon started cas2-authentication (id: cas2-authentication-1.5.3) addon started nuxeo-dam (id: nuxeo-dam-6.3.3) addon started nuxeo-drive (id: nuxeo-drive-1.7.4) addon started nuxeo-jsf-ui (id: nuxeo-jsf-ui-9.10.0-HF01) addon started nuxeo-platform-importer (id: nuxeo-platform-importer-1.8.3) addon started nuxeo-showcase-content (id: nuxeo-showcase-content-1.2.3)

05/03/2018

I am not very sure but seems like problem lies in dependency between DAM and JSF UI. My opinion will be:

  1. Uninstall all jsf add-ons.
  2. Then install "nuxeo-jsf-ui (id: nuxeo-jsf-ui-9.3.0)"
  3. Start the server.

See if it works

05/03/2018


Is it getting timed out while start?

0 votes



No, because we set this value : launcher.start.max.wait=3600 launcher.stop.max.wait=3600
04/30/2018