Default credentials not working for first login

Good morning,

I'm using a VM with W2008 R2, I have installed a Postgre 9.1 I have installed the nuxeo windows installer 5.5

The installation works fine, I saw the nuxeo base created with 48 tables

But when I try to connect with the Administrator/Administrator credentials, Nuxeo said that these credentials are uncorrect

Thanks in advance

JLBETIN

0 votes

2 answers

8747 views

ANSWER



One of the reasons you cannot connect with user Administrator is that the database is not correctly configured. If this is the case you will find some meaningful error messages in the logs [1].

Did you follow this documentation : http://doc.nuxeo.com/x/fwQz

[1]: I created an answer entry to explain how to find it here.

0 votes



Sorry to answer late. I was so upset that I have reformated my VM and reinstalled completely everything including nuxeo. At last this problem was probably due to the fact that another version of Postgres was already there and that may have created a mismatch during installation ??
01/02/2012


Bjalon points to the full tuning of postgresql which you should absolutely follow-up on.

Based on the fact you are getting only 48 tables created and you can't login, my experience is that you need to ensure (1) plpgsql is enabled on the database (s/b ddflt for 9.x but not for 8.4), and (2) ensure that the database has implicit casts set…

CREATE FUNCTION pg_catalog.text(integer) RETURNS text STRICT IMMUTABLE LANGUAGE SQL AS 'SELECT textin(int4out($1));'; CREATE CAST (integer AS text) WITH FUNCTION pg_catalog.text(integer) AS IMPLICIT; COMMENT ON FUNCTION pg_catalog.text(integer) IS 'convert integer to text';

CREATE FUNCTION pg_catalog.text(bigint) RETURNS text STRICT IMMUTABLE LANGUAGE SQL AS 'SELECT textin(int8out($1));'; CREATE CAST (bigint AS text) WITH FUNCTION pg_catalog.text(bigint) AS IMPLICIT; COMMENT ON FUNCTION pg_catalog.text(bigint) IS 'convert bigint to text';

This should allow you to login… even if you don't undertake all the other tuning steps immediately.

0 votes