nuxeo 9.10 Invalid cookie header

Hello, I can't install new packages on my nuxeo instance from the marketplace or from the command line.

I'm running nuxeo 9.10 withouth any hotfix installed.

everytime I execute a command line such as

./nuxeoctl mp-install fix-cve-2021-44228-1.0.0

I get this logs :

Invalid cookie header: "Set-Cookie: AWSALB=uSaF7oTxLVNovq2HXRW9AAX3w7DCdur66Ui7jw8z2GBodFUTFQ79NNqEYZTXM4zdR2jN9OvuHM80Bo5qOC/Y5jZgMfxZmhyAWXaRRVaIY+40yfBEH2otOQ1gK4WK; Expires=Fri, 24 Dec 2021 11:09:03 GMT; Path=/". Invalid 'expires' attribute: Fri, 24 Dec 2021 11:09:03 GMT

Invalid cookie header: "Set-Cookie: AWSALBCORS=uSaF7oTxLVNovq2HXRW9AAX3w7DCdur66Ui7jw8z2GBodFUTFQ79NNqEYZTXM4zdR2jN9OvuHM80Bo5qOC/Y5jZgMfxZmhyAWXaRRVaIY+40yfBEH2otOQ1gK4WK; Expires=Fri, 24 Dec 2021 11:09:03 GMT; Path=/; SameSite=None; Secure". Invalid 'expires' attribute: Fri, 24 Dec 2021 11:09:03 GMT

Invalid cookie header: "Set-Cookie: AWSALB=RnlTHSsp8gOY5UP/C6SlF/3nbaY9NY+nujZQADSAh4gz5bq/H/AaPgAmGFV3hNg586Dmo0P2AVS+qJOaBjr826ARdgdWq4z5uuoMwpOb8ScQnu3G9xBTnIO2+VM1; Expires=Fri, 24 Dec 2021 11:09:04 GMT; Path=/". Invalid 'expires' attribute: Fri, 24 Dec 2021 11:09:04 GMT
Invalid cookie header: "Set-Cookie: AWSALBCORS=RnlTHSsp8gOY5UP/C6SlF/3nbaY9NY+nujZQADSAh4gz5bq/H/AaPgAmGFV3hNg586Dmo0P2AVS+qJOaBjr826ARdgdWq4z5uuoMwpOb8ScQnu3G9xBTnIO2+VM1; Expires=Fri, 24 Dec 2021 11:09:04 GMT; Path=/; SameSite=None; Secure". Invalid 'expires' attribute: Fri, 24 Dec 2021 11:09:04 GMT
Invalid cookie header: "Set-Cookie: AWSALB=4arfQAYhcXaaLMOQbtx+EzYp297i+uNi/iV9tfuYon8LW5e6xRkuAMjATmPX9YlPdqDbVoUS4UPny7IQ5lGtdWSG3gRLXAqGuaYx1u09k8GU6BDMgfuwsTtZt2ck; Expires=Fri, 24 Dec 2021 11:09:04 GMT; Path=/". Invalid 'expires' attribute: Fri, 24 Dec 2021 11:09:04 GMT
Invalid cookie header: "Set-Cookie: AWSALBCORS=4arfQAYhcXaaLMOQbtx+EzYp297i+uNi/iV9tfuYon8LW5e6xRkuAMjATmPX9YlPdqDbVoUS4UPny7IQ5lGtdWSG3gRLXAqGuaYx1u09k8GU6BDMgfuwsTtZt2ck; Expires=Fri, 24 Dec 2021 11:09:04 GMT; Path=/; SameSite=None; Secure". Invalid 'expires' attribute: Fri, 24 Dec 2021 11:09:04 GMT
Dependency resolution:
Installation order (1): fix-cve-2021-44228-1.0.0

Unchanged packages (18): nuxeo-9.10-HF11:1.0.0, nuxeo-9.10-HF10:1.0.0, nuxeo-9.10-HF02:1.0.0, nuxeo-9.10-HF13:1.0.0, nuxeo-9.10-HF01:1.0.1, nuxeo-9.10-HF12:1.0.0, nuxeo-9.10-HF04:1.1.0, nuxeo-9.10-HF15:1.0.0, nuxeo-9.10-HF03:1.0.1, nuxeo-9.10-HF14:1.0.0, nuxeo-9.10-HF06:1.1.0, sid.ulr:0.0.0-SNAPSHOT, nuxeo-9.10-HF05:1.1.0, nuxeo-9.10-HF08:1.0.0, nuxeo-9.10-HF07:1.0.0, nuxeo-api-playground:1.2.4, nuxeo-9.10-HF09:1.0.0, nuxeo-jsf-ui:9.10.0-HF01

Packages to download (1): fix-cve-2021-44228:1.0.0

Do you want to continue (yes/no)? [yes] yes

Downloading [fix-cve-2021-44228-1.0.0]...

Invalid cookie header: "Set-Cookie: AWSALB=+rUyEtOPgErOHe/qCMvtgllqj/atqQ7eiE7EPEl0BoPFei7QGl9ys/2lCT0Ebq+nXW5zodQheeElV5ZLXj385JhX3d6tXChjLBRh1GeIQci4U+ZRs1wniNMR+Ido; Expires=Fri, 24 Dec 2021 11:09:22 GMT; Path=/". Invalid 'expires' attribute: Fri, 24 Dec 2021 11:09:22 GMT

Invalid cookie header: "Set-Cookie: AWSALBCORS=+rUyEtOPgErOHe/qCMvtgllqj/atqQ7eiE7EPEl0BoPFei7QGl9ys/2lCT0Ebq+nXW5zodQheeElV5ZLXj385JhX3d6tXChjLBRh1GeIQci4U+ZRs1wniNMR+Ido; Expires=Fri, 24 Dec 2021 11:09:22 GMT; Path=/; SameSite=None; Secure". Invalid 'expires' attribute: Fri, 24 Dec 2021 11:09:22 GMT

Invalid cookie header: "Set-Cookie: AWSALB=txZeOEUIGRfUWH4MwxfkUvZBb+Fz5KUdKzkCFUhQvcdINWyBlYZOuwU3huoeFmnVubsVIK7F3IWVOzOaL5tSVIEbd1NhyzNxyKwRw/FXHxrhMjTfoSUDncn3iZDz; Expires=Fri, 24 Dec 2021 11:09:22 GMT; Path=/". Invalid 'expires' attribute: Fri, 24 Dec 2021 11:09:22 GMT

Invalid cookie header: "Set-Cookie: AWSALBCORS=txZeOEUIGRfUWH4MwxfkUvZBb+Fz5KUdKzkCFUhQvcdINWyBlYZOuwU3huoeFmnVubsVIK7F3IWVOzOaL5tSVIEbd1NhyzNxyKwRw/FXHxrhMjTfoSUDncn3iZDz; Expires=Fri, 24 Dec 2021 11:09:22 GMT; Path=/; SameSite=None; Secure". Invalid 'expires' attribute: Fri, 24 Dec 2021 11:09:22 GMT

Invalid cookie header: "Set-Cookie: AWSALB=Ht0Bd/U0u+aGOXM77racM67rgTBhtQjCquSKR8uoZGuyTELvCHaQ9zgAOPynu+6ZEr1MkJ+aRaOii0hnF+LXbJlxbWhvtlnY2Vjq/yhWY8RDBYdGRIAPkUHvrVhz; Expires=Fri, 24 Dec 2021 11:09:22 GMT; Path=/". Invalid 'expires' attribute: Fri, 24 Dec 2021 11:09:22 GMT

Invalid cookie header: "Set-Cookie: AWSALBCORS=Ht0Bd/U0u+aGOXM77racM67rgTBhtQjCquSKR8uoZGuyTELvCHaQ9zgAOPynu+6ZEr1MkJ+aRaOii0hnF+LXbJlxbWhvtlnY2Vjq/yhWY8RDBYdGRIAPkUHvrVhz; Expires=Fri, 24 Dec 2021 11:09:22 GMT; Path=/; SameSite=None; Secure". Invalid 'expires' attribute: Fri, 24 Dec 2021 11:09:22 GMT

Invalid cookie header: "Set-Cookie: AWSALB=1ChHEOBNSiIvaQgYfcpllNSBxuu5UZNN5uUM0RhVBIeR3pDg19ffzQzI1L4pqb/JhDtBz4kAPrnzc/WDbi7n96zW6I1afs97NzirOGGxf8ofTdXbRZWibMOfWfgB; Expires=Fri, 24 Dec 2021 11:09:22 GMT; Path=/". Invalid 'expires' attribute: Fri, 24 Dec 2021 11:09:22 GMT

Invalid cookie header: "Set-Cookie: AWSALBCORS=1ChHEOBNSiIvaQgYfcpllNSBxuu5UZNN5uUM0RhVBIeR3pDg19ffzQzI1L4pqb/JhDtBz4kAPrnzc/WDbi7n96zW6I1afs97NzirOGGxf8ofTdXbRZWibMOfWfgB; Expires=Fri, 24 Dec 2021 11:09:22 GMT; Path=/; SameSite=None; Secure". Invalid 'expires' attribute: Fri, 24 Dec 2021 11:09:22 GMT

Aborting packages change request
Failed commands:
* download (fix-cve-2021-44228-1.0.0)
Download failed: Registration required (401).
0 votes

1 answers

142 views

ANSWER



Hello,

This invalid cookie header shouldn't affect the package installation. I've noticed the Download failed: Registration required (401). error, this is the most important issue. Are you sure your instance is registered by running the ./nuxeoctl register command?

Thx

0 votes