Error if you change nuxeodm database password during initial configuration

Using Ubuntu Linux Ubuntu 10.04.3 LTS I installed nuxeo-dm using synaptic. This also installed Postgres.

During the configuration screens, I saw a password for the postgres database user which I did not know (it was blanked out), so I changed the password for the nuxeodm user.

I could then access the webpage http://localhost:8080

But I could not login using the Administrator/Administrator name/password.

Investigating with the help of http://forum.nuxeo.com/t/4433/ I saw that Nuxeo was failing to connect to the Postgres database.

Trying

psql -h localhost -p 5433 -U nuxeodm -W nuxeodm

manually, I could login using the ORIGINAL nuxeodm password, but not with the new password that I had set. Looking in /etc/nuxeo-dm/nuxeo.conf I saw

nuxeo.db.password={original password}

nuxeo.db.password={original password}

nuxeo.db.password={new password}

ie there were two uncommented nuxeo.db.password lines. It seems as tho the postgres database was set up to use the original password, but Nuxeo was trying to connect using the new password.

I got it working by reinstalling Nuxeo and postgres.

So looks like there is something wrong about the configuration screens if you try to use them to change the nuxeodm database user's password.

1 votes

1 answers

2439 views

ANSWER

This sounds like a bug report and nuxeo's JIRA system would be more appropriate for posting this kind of content. Please use: http://jira.nuxeo.com/
10/05/2011

OK. Added as a bug report on JIRA as
Nuxeo ECM Build/Test Environment NXBT-327
10/05/2011



Actually, there's two different things here:

  • when you choose to autoconfigure postgresql in the deb package options, it will pick a random password and create a database and user with that password, and set those parameters in nuxeo.conf. It's just a helper to not have to configure the whole database back-end parameters manually and is not part of the Nuxeo platform per se.
  • when you change the password in the startup wizard (or the admin center), it just impacts the nuxeo.conf parameters.

So yes, if you use the automatic database installation then change the password the application uses in the wizard, it won't be able to connect to the database.

It's not really a bug, but it can certainly be confusing. We should probably have a way to hide the database configuration page in the wizard(or make the fields non-editable) when using the “autoconfigure” option in the package.

1 votes