Update package via Studio fails: UpdateManager.java looks for wrong themes-path

Update directly from Studio

I run Nuxeo LTS 2016 in the default/official Docker image. Recently the update mechanism via Studio keeps failing, but it had worked before. No idea why it's not working, but I can see that the UpdateManager is looking for a wrong path for the themes-folder.

The project is properly registered and the status looks like this:

type an image title

(click the files link at the bottom of this post to enlarge)

Package info and dependencies:

type an image title

(click the files link at the bottom of this post to enlarge)

Checking the startup log under monitoring: (Complete log here: http://pastebin.com/J0zaRxwx)

1. Caused by: org.nuxeo.connect.update.PackageException: Failed to copy file: /opt/nuxeo/server/nxserver/bundles/evaluationproject-conrad-master-SNAPSHOT.jar to /opt/nuxeo/server/packages/backup/nxserver/bundles/evaluationproject-conrad-master-SNAPSHOT.jar
2. at org.nuxeo.connect.update.task.update.UpdateManager.copy(UpdateManager.java:467)
3. at org.nuxeo.connect.update.task.update.UpdateManager.backupFile(UpdateManager.java:425)
4. ... 117 more
5. Caused by: java.io.FileNotFoundException: /opt/nuxeo/server/packages/backup/nxserver/bundles/evaluationproject-conrad-master-SNAPSHOT.jar/evaluationproject-conrad-master-SNAPSHOT.jar/themes (Not a directory)
6. at java.io.FileOutputStream.open0(Native Method)
7. at java.io.FileOutputStream.open(FileOutputStream.java:270)
8. at java.io.FileOutputStream.<init>(FileOutputStream.java:213)
9. at java.io.FileOutputStream.<init>(FileOutputStream.java:162)
10. at org.nuxeo.common.utils.FileUtils.copyFile(FileUtils.java:366)
11. at org.nuxeo.common.utils.FileUtils.copyTree(FileUtils.java:386)
12. at org.nuxeo.common.utils.FileUtils.copyTree(FileUtils.java:396)
13. at org.nuxeo.common.utils.FileUtils.copyTree(FileUtils.java:396)
14. at org.nuxeo.common.utils.FileUtils.copyTree(FileUtils.java:396)
15. at org.nuxeo.common.utils.FileUtils.copy(FileUtils.java:349)
16. at org.nuxeo.connect.update.task.update.UpdateManager.copy(UpdateManager.java:464)

Checking the mentioned folder on Docker container / command line, I think that the path where the UpdateManager is looking for the themes-folder is wrong. It has the evaluationproject-conrad-master-SNAPSHOT.jar twice in its name!

/opt/nuxeo/server/packages/backup/nxserver/bundles/evaluationproject-conrad-master-SNAPSHOT.jar/evaluationproject-conrad-master-SNAPSHOT.jar/themes

type an image title

(click the files link at the bottom of this post to enlarge)


Manual upload

In a second attempt, I tried to go to “Admin > Update Center > Local Packages > [Package]” and click the “install” button there. Afterwards I get the info that a server restart is required.

type an image title

(click the files link at the bottom of this post to enlarge)

Restarting the Nuxeo server via command line in the Docker container nuxeoctrl restart which gives me these errors:

Installing evaluationproject-conrad-0.0.0-SNAPSHOT

Failed to install package: evaluationproject-conrad-0.0.0-SNAPSHOT (Failed to backup file: nxserver/bundles/evaluationproject-conrad-master-SNAPSHOT.jar)

Pending actions execution failed. The commands file has been moved to: /var/lib/nuxeo/data/installAfterRestart.log.bak

Start interrupted due to failure on pending actions. You can resume with a new start; or you can restore the file 'installAfterRestart.log', optionally using the '--ignore-missing' option.

Failed commands:
* install (evaluationproject-conrad-0.0.0-SNAPSHOT)
Failed to backup file: nxserver/bundles/evaluationproject-conrad-master-SNAPSHOT.jar

(click the files link at the bottom of this post to enlarge)

Log: http://pastebin.com/8pbyTjmZ


Manual Installation

In a third attempt, I removed the package via the Nuxeo Admin section, then downloaded the jar and installed it as per instructions.

This seems to work without errors.

0 votes

0 answers

61 views

ANSWER

I recreated a fresh Docker container today (same version, same package/project) and tested it and the problem does not exist anymore. Let's see if the error happens again at some point later.
01/31/2017