Error while updating Studio Project

Hi All,

I am getting following error while updating my studio project from FT 9.1 to FT 9.2.

ERROR [ConnectDownloadThread-1-3] [org.nuxeo.connect.downloads.LocalDownloadingPackage] Package project1-acheron-softwar-0.0.0-SNAPSHOT is already installed

I had installed FT 9.1 Nuxeo server and had created some custom documents, automation chains and event handlers along side some custom extension points. Yesterday I upgraded my Nuxeo Platform from 9.1 to 9.2. After this, I am facing issues with the upgrade of my Studio Project. Whenever I click “Update” button from Update Center in Nuxeo platform, server status shows its restarting and it hangs there. Nothing else happens and no error logs except for the above mentioned error. I have to stop the server manually and start it again for Nuxeo Platform to be up and running again.

Also, notice that the package version is 0.0.0 but prior to upgrade from 9.1 it used to be 0.0.1 and its same in my studio project.

I have upgraded my Nuxeo Studio application dependency target platform to 9.2.

Can some one let me know what is wrong with my configuration ?

EDIT: Attached the snapshot of the error (Error.png) that I see each time when I try to deploy my studio project after starting Nuxeo server

Added Error_1.png after updating nuxeo.conf to use org.nuxeo.runtime.reload_strategy=standby

0 votes

1 answers

1040 views

ANSWER

I am wondering why did you remove your studio project manually, and not through nuxeoctl command (uninstall/purge). Is there any specific reason, did you have any trouble with running it?
07/27/2017

Initially when I started facing issues, I tried uninstalling from the Update Center in Nuxeo Platform under "Local Packages" tab. But it was not uninstalling. I got an error stating Cannot uninstall Commands file are missing. When I checked the logs the error was Could not find uninstall.xml for the project. So I deduce that there was some issue with the studio project and hence cleaned it manually. I understand it is not recommened to uninstall manually. However, you can please let me know if its because of that I am seeing my project version as 0.0.0 and my branc management version is 0.0.2
07/27/2017



Hi,

could you check what packages are installed, and see if you have multiple packages of your studio project?

0 votes



Hi Ronan Daniellou Thank you for your reply.

I do not see multiple packages of my studio project, below are the packages that are installed in my server (The list is taken from .packages file, located in NUXEO_HOME\packages\.packages)

nuxeo-api-playground-1.1.2=started nuxeo-drive-1.7.1=started nuxeo-web-ui-1.1.2=started nuxeo-dam-6.3.1=started project1-acheron-softwar-0.0.0-SNAPSHOT=installing nuxeo-jsf-ui-9.2.0=started *nuxeo-multi-tenant-1.7.1=started

Notice that my project status is "Installing". This is the latest status of my server. I have updated the screenshot of the error in my question as well.

07/26/2017

Hi, We introduce a new mechanism for hot reload in 9.2. To preserve compatibility and do more tests before releasing it we also introduce a compatibility mode. I can see on your screenshot (last line) that you use the restart strategy. This is not a supported strategy right now, you should use unstash instead, which is the one used in the 9.2, by adding to your nuxeo.conf:

org.nuxeo.runtime.reload_strategy=unstash

You didn't have this property because you probably use your 9.1 nuxeo.conf file.

Tell me if you still have trouble.

07/26/2017

Hi Kevin Leturc Thank you for your reply. I did exactly as you mentioned and updated nuxeo.conf with the property as mentioned. But I do not see any change. Now also when I try to update the studio project from "Update Center" it just keeps loading. I have updated my question with Error_1.png and it shows that its using the unstash reload strategy.

To be exactly clear I did the following steps,

  • Stopped the Nuxeo Server
  • Updated nuxeo.conf with the strategy you mentioned
  • Removed the project1-acheron-softwar-0.0.0-SNAPSHOT=installing from .packages file
  • Removed my studio project jar fromNUXEO_HOME\nxserver\bundles directory.
  • Removed my studio project jar from NUXEO_HOME\packages\backup\nxserver\bundles directory
  • Removed my studio project folder created under NUXEO_HOME\packages\store
  • Started the server and Logged in and clicked "Update" from "Update Center".

Can you kindly let me know if there is something that is gone wrong here ?

07/26/2017

I can see on Error_1.png that server uses the standby strategy. I was talking about unstash strategy and gave you a configuration line for standby strategy. You need to set unstash instead of standby to the configuration property. I updated my previous comment to reflect the correct solution. Sorry for the inconvenience.
07/26/2017

OK. I will check that. Meanwhile can you please let me know the steps that I followed, in my previous comment, after the configuring the conf file (removing studio project references before starting server) is fine or correct way to do it ?
07/26/2017

Awesome ! Thank you Kevin Leturc your suggestion worked and I am able to update studio project. I did a quick test by creating an automation chain and it works. Thank you. However, I am still wondering why the studio project version is displayed as 0.0.0 in my local packages tab whereas my branch version currently is 0.0.2 ?
07/27/2017

This is due to some legacy. The admin center of the Nuxeo instance uses 0.0.0-SNAPSHOT, but Studio, when serving the package, will put the content of the checked out branch of the user who has registered the instance against the project.
07/28/2017