Getting error while updating package

Getting below error while doing update to the package from the platform.

Error: This package is not validated for your current platform:cap-5.8

I have installed the hot fix for 5.8 but still I am facing the same issue

0 votes

7 answers

2051 views

ANSWER

Which package and version are you trying to update ? Also, you can use the command line to get more information about the package : ./nuxeoctl mp-show mpypackage And check your version of Nuxeo corresponds to the target platform
04/01/2014

I have created some users, document Items, schemas using trail version of Studio, I was trying to update these changes in my Nuxeo Platform. I have registered my Studio Trail version in Nuxeo Platform using Nuxeo Connect. After registering I am trying to update the platform with the latest configurations saved in Studio using update in the Update Center and I am getting the below error

Error: This package is not validated for your current platform:cap-5.8

Please help me in resolving this.

04/01/2014



I created the users and groups with “Creation Policy” set to “Always”. But I am unable to login with Administrator account. Please let me know how can I restore my Administrator Account as I have created a non admin user and I am unable to do anything now with my new user.

0 votes



Looks like you did everything correctly. Just, to make sure, once the server is started and you are in the Admin Center, you did bind the correct Studio project to the server (in the Nuxeo Connect sub tab) ?

In the “Update Center” tab, got to “Local Packages” and check if you see your Studio project. You should see it and only one (plus the other Nuxeo packages such as DM or DAM for example)

For users and groups, in Studio, if you want your users to be created in the server everytime you update the server, you must set the “Creation policy” to “Always”, because once a set has been created, the colums exist so they are not re-created.

For Documents (you don't see the schemas in the UI), could you just go in the degault domain, open “workspaces”, and create a new workspace. Once in this workspace, click the “New” button: In the creaiton dialog you should see your document type.

0 votes



Hi Thibarg,

I have reinstalled my Nuxeo platform 5.9.2. I have created schemas, users, groups and DocumentItems using Nuxeo Studio. I have registered my Nuxeo Studio Instance using Nuxeo Connect.In “Settings & Versioning” I have set the “Target Platform” to 5.9.2. And also have set the “Commit Style” to “On Save”. Now I am trying the update the platform with the latest configurations saved in studio using “update” in Admin Center. Its updating successfully and also I have restarted the server. After login into site I dont see any configurations which I have created in Nuxeo Studio for ex: Groups, Users, schemas, Document Items etc.

Please let me know the step by step process to update the platform with the latest configurations saved in studio using “update” in Admin Center.

0 votes



Hi Thibarg,

I checked the log file and I see the following Exception

2014-04-04 18:24:28,694 ERROR [ajp-bio-0.0.0.0-8009-exec-23] [org.jboss.seam.jsf.SeamPhaseListener] swallowing exception javax.el.ELException: java.lang.IllegalArgumentException: Not a folder

Please let me know if you need more info.

0 votes



Actually, a bit more of the log could maybe help. Not sure, but still, because here we have this exception, but no info about which folder is missing for example.

I can't see why installing the Studio project would break the server…

It is hard to guess what is happening and what has happened. So the quick and easy way to let you work with Nuxeo could be to just reinstall it if it is possible (remove previous version and re-install it.) Is is possible?

On the Studio Project side, you have no warnings, no errosrs? (whene there is an error, some flashy read tags are displayed in the tree view)

04/04/2014


Thanks Thibarg for your reply.

I have made changes as per your suggestion and now when I am trying to login to the system, I am getting the below mentioned error.

If you can read this in your browser, this probably because of a configuration problem of your nuxeo.war/WEB-INF/pages.xml. To change this, edit the OSGI-INF/deployment-fragment.xml of your project at extension pages#PAGES.

Please help in resolving this error.

0 votes



Well, this is strange.

Did you try to just stop/start the server?

Also, could you check the server.log file? It is in a "log" folder. The location of this folder depends on the OS and the installation:

The server should log the reason why this suddenly failed.

04/03/2014


Have you checked the versioning in your Studio project? Once you are in your project:

  • Go to “Settings & Versioning” (bottom of the tree view on the left)
  • “Project Settings”
  • Check “Target Platform” is set on 5.8, if not, set it to 5.8 and save. I also recommend, at the beginning of configuration, to set the “Commit Style” to “On Save”.

Please, let us know if this solved your issue.

0 votes



I have created some users, document Items, schemas using trail version of Studio, I was trying to update these changes in my Nuxeo Platform. I have registered my Studio Trail version in Nuxeo Platform using Nuxeo Connect. After registering I am trying to update the platform with the latest configurations saved in Studio using update in the Update Center and I am getting the below error

Error: This package is not validated for your current platform:cap-5.8

Please help me in resolving this.

0 votes