Nuxeo Installation Error - PSQLException

after running

# apt-get install nuxeo

I'm getting this error:

[....] Starting: Nuxeo\norg.postgresql.util.PSQLException: FATAL: Passwort-Authentifizierung f?r Benutzer >>nuxeo<< fehlgeschlagen
Could not run configuration: Failed to connect on database: FATAL: Passwort-Authentifizierung f?r Benutzer >>nuxeo<< fehlgeschlagen
 failed!
invoke-rc.d: initscript nuxeo, action "start" failed.
dpkg: error processing nuxeo (--configure):
 subprocess installed post-installation script returned error exit status 6
Errors were encountered while processing:
 nuxeo
E: Sub-process /usr/bin/dpkg returned an error code (1)

I've tried anything I could but without success.

My system:

root@nuxeo:~# lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 7.2 (wheezy)
Release:    7.2
Codename:   wheezy

I would be glad if someone could help me…

UPDATE: now I'm getting this one (after removing anything to do with postgresql):

Setting up nuxeo (5.7.3-01) ...
[....] Starting: Nuxeo\norg.postgresql.util.PSQLException: Connection refused. Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections.
Could not run configuration: Failed to connect on database: Connection refused. Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections.
 failed!
invoke-rc.d: initscript nuxeo, action "start" failed.
dpkg: error processing nuxeo (--configure):
 subprocess installed post-installation script returned error exit status 6
Errors were encountered while processing:
 nuxeo
E: Sub-process /usr/bin/dpkg returned an error code (1)
0 votes

2 answers

2546 views

ANSWER



Hello,

The two main reasons this can happen are:
1) There is not enough memory to start an additional PostgreSQL “cluster” for Nuxeo during installation, so the user is never created in the database,
2) The configuration file was overwritten during an upgrade and so the configuration is no longer correct.

0 votes



Hi,

There may be some conflicts when you already have a PostgreSQL cluster installed.

I'll let our administrator look deeper at your issue but this is usually a credential issue and an easy way to fix it is to manually configure the PostgreSQL database and accordingly update your DB configuration (in /etc/nuxeo/nuxeo.conf)

Regards,

0 votes