How do I restore apt-get to proper working order after a failed install of Nuxeo?

I tried to install Nuxeo on my Ubuntu 12 server. I followed the instructions posted at http://doc.nuxeo.com/display/public/ADMINDOC/Installing+the+Nuxeo+Platform+on+Linux

The instructions did not provide a warning that Java 7 is required. Generally with apt-get, required dependencies are installed. So I figured apt-get would just do its thing. Sadly I happen to already have Java 6 installed. For some reason the Nuxeo install, via “apt-get install nuxeo” wasn't happy about that, reporting:

Could not run configuration: Nuxeo requires Java {1.7} (detected 1.6.0_27).

I now have two Java JDKs installed, both OpenJDK. But the default one is still Java 6. For example if I enter “java -version” I get:

java version "1.6.0_27"
OpenJDK Runtime Environment (IcedTea6 1.12.6) (6b27-1.12.6-1ubuntu0.12.04.4)
OpenJDK Server VM (build 20.0-b12, mixed mode)

I tried to flat-out remove Java 6, with “apt-get remove openjdk-6-jdk” . But it seems that apt-get is now in some sort of limbo. It wants to complete the Nuxeo install, but it fails, with:

Setting up nuxeo (5.9.1-01) ...
 * Starting Nuxeo

Could not run configuration: Nuxeo requires Java {1.7} (detected 1.6.0_27).  [fail]
invoke-rc.d: initscript nuxeo, action "start" failed.
dpkg: error processing nuxeo (--configure):
 subprocess installed post-installation script returned error exit status 6
Errors were encountered while processing:
 nuxeo
E: Sub-process /usr/bin/dpkg returned an error code (1)

So, does anyone know how to get apt-get “unstuck” ?

0 votes

2 answers

1333 views

ANSWER



sudo service nuxeo stop
sudo apt-get remove nuxeo

0 votes



Oh, wow, I should have figured that out. Thanks for the clue.
01/20/2014


I had the same Problem with version 1.7 / 1.8 and wasn't able to just remove nuxeo. The solution was to manually delete the nuxeo user before removing nuxeo:

sudo service nuxeo stop  
sudo sed -i '/^nuxeo/ d' /etc/passwd
sudo apt-get remove nuxeo
0 votes