What's happened to the preview button?

I'm running Nuxeo 5.7.2, although I've been experiencing the same problems since 5.6.

When I install on Debian (7, Wheezy), as per the installation instructions, everything seems to work fine, but there is no preview button. I realise there were preview problems in Debian previously, but I wasn't aware the button could disappear, so I thought the function had been dropped from the system.

Just to check, I installed Nuxeo 5.7.2 on Ubuntu 13.04 (Desktop, not server), and it installs in the same way, but now there is a preview button when editing a file (with an 'eye' icon).

What does this mean? Is it that the installer (using apt-get) doesn't configure and start the LibreOffice listener correctly (a problem that I've been experiencing for years now, on OpenBSD, FreeBSD and Debian), so it removes the button altogether, or is there an advanced configuration option I'm not aware of.

For what it's worth, I set Nuxeo up on Debian with PostgreSQL as database, while on Ubuntu I just didn't have the time to waste (the installer fails to set up PostgreSQL correctly on both platforms, leaving the admin to fix the postgresql.conf manually, then start it up), using just the built-in database (H2?).

I'd like to know if there are problems on Debian that just haven't been discussed/fixed yet?

Thanks,

Sacha

0 votes

0 answers

984 views

ANSWER

Hi,

Sorry, this does not ring any bell, maybe the preview is not available for some other reason than an installation issue, for instance the document in question does not have anything to offer for preview (?)

09/21/2013

Further to my original post, and to Anahide,

I've once again tried this, in Nuxeo 5.7.3. I set up a Xen virtual machine, with 2 CPUs and 1.5Gb RAM. I installed:

  1. Debian 7
  2. Ubuntu 12.04 LTS
  3. Ubuntu 13.04

all with their default options, then Nuxeo as per instructions at http://doc.nuxeo.com/display/ADMINDOC/Installing+the+Nuxeo+Platform+on+Linux;jsessionid=569776A7336447EC98A183A70EA8F6BF. As before, in Debian, PostgreSQL is misconfigured, so I removed it from nuxeo.conf, commenting out the 'template' line to use H2.

I then logged on to Nuxeo (having first gone through the wizard, only in the Ubuntus) as Administrator, added a new workspace, and uploaded two documents: an '.odt' and a PDF.

As before, in Debian there is no preview button, in both the Ubuntus, there is. There is no 'eye' icon in the Debian instance, yet there is in both Ubuntu instances. Bear in mind that these are stock-installs of Nuxeo on 'virgin' os installations. I can provide screenshots, I just don't know how to attach them to this post.

So, is Debian a second-class citizen, like the BSDs are? Is Ubuntu Nuxeo's favoured hosting server? Does Nuxeo 'hide' the preview function if the OpenOffice server can't be reached?

Thanks,

Sacha

09/27/2013

The package is the exact same on Ubuntu and Debian, and we do use it on both without issue, so no Debian is not a second-class citizen :)
The latest versions don't work on Squeeze (due to bash 4 unavailability IIRC) but apparently you're on Wheezy.

Your issue with PostgreSQL may be due to not enough RAM for the VM: the package creates a new PostgreSQL "cluster" to avoid messing with the main configuration, it's possible there's some difference in memory management that makes it work for you on Ubuntu but not on Debian (though I would expect it to be the other way around…).

As for the preview, I think it was moved from the base CAP to DM (not 100% sure about this), do you have the DM package installed on both instances?

09/27/2013

Hi Mathieu,

Yes, I'm on Wheezy. Glad to hear Debian's still getting some 'love' :)

The only problems with PostgreSQL on Debian were with the configuration file, postgresql.conf. A number of [locale] options are specified, in my instance, with the UTF-8 GB locale, which PostgreSQL doesn't recognise for certain options. For some it's fine left as-is, on others, it's easy to comment the offending option out. This part is no big deal, for me.

As for the RAM, well I don't think this is a problem. The cluster is correctly created in both Debian and Ubuntu, again, it's only down to the configuration file. As I'm installing in the very same container, the memory can not be the problem! If anything, the stock Ubuntu installation is much more large, needing more disk space. Knowing the distribution, their memory footprint is likely to be larger as well.

As for the last question, yes it's the DM I'm installing on all three instances.

So, bottom line, there's something preventing the DM from displaying the preview icon. If you'd like to see, I'll happily forward you the three screenshots to an email address you nominate.

09/27/2013

This might seem a little simple, but have you checked the logs after an install, or actively tailed the logs while doing the install? It might show you If there is anything happening on the different installs.

Just a thought. Also, which PostgreSQL are you using?

10/16/2013