Server will not start - 5.5 tomcat

We have been running 5.4.2 for a while now with no problems. We decided to do a new install of 5.5 and migrate the data over. We were able to start the server, import some test data, and everything worked fine. When we actually brought the real data over, nuxeoctl would not start the server. Here are the errors from server.log: http://pastebin.com/J20dVTrC

0 votes

1 answers

649 views

ANSWER

How did you migrate the data from 5.4.2 to 5.5?

> Caused by: java.io.FileNotFoundException: /home/var/lib/nuxeo/bundles.ids (No such file or directory)

Also, what Nuxeo 5.4.2 was it (CAP, DM, …)? Since 5.5, you install Nuxeo (CAP) then choose the wanted modules to install (DM, …).

03/13/2012



I installed the nuxeo code on the new server from the zip archive available on a nuxeo server.

I made a postgresql dump of the data on the working system and then included that and the document tree (to which my nuxeo.data.dir refers) in a tar file, which I untar'd and set up on the new server.

I found that a small typo (sh instead of su) on my part when starting nuxeo for the first time caused parts of the nuxeo tree itself as well as nuxeo.data.dir to have the wrong file ownership, which caused problems later. I fixed that by sudo chown -R nuxeo:nuxeo on both trees.

Service actually worked correctly when I boosted the memory allocations for virtual memory of the java process and the three memory allocations for java near the top of nuxeo.conf . java takes much more memory (more than twice as much) to run on a 64-bit architecture host as on a 32-bit architecture host.

1 votes



So, everything is working fine now?
03/19/2012

Yes, It is working fine now, and has worked great for over a year. We are now in the process of trying to upgrade to 5.6. and then possibly to 5.7.2.

It seemed that the answer was to update the memory, and make sure all permissions were set right.

08/26/2013