Fresh install leads to error 310 net::ERR_TOO_MANY_REDIRECTS in Chrome

Hi guys,

I've just installed Nuxeo 5.5 on a brand new server with Ubuntu 10.04 LTS 64-bit. The procedure I've followed is stated here: http://doc.nuxeo.com/display/ADMINDOC/Installing+the+Nuxeo+Platform+on+Linux I followed the installation wizard using all default values. All went well, so after a while I was presented with the new welcome screen for Nuxeo 5.5. Logged in using Administrator (username), Administrator (password) and then I got an error in Google Chrome:

This webpage has a redirect loop The webpage at http://vm652.xplicare.com:8080/nuxeo/nxstartup.faces?conversationId=0NXMAIN20 has resulted in too many redirects. Clearing your cookies for this site or allowing third-party cookies may fix the problem. If not, it is possibly a server configuration issue and not a problem with your computer. Here are some suggestions: Reload this webpage later. Learn more about this problem. Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects.

I don't really know how to fix this, everything's installed using default values, so there are no weird custom configurations. Is this an error in the deb-package? Can anybody help me? Thanks in advance for your help.

Regards,

Paul

1 votes

2 answers

1768 views

ANSWER

Possibly a browser config/cache issue. Take a look at this Google Chrome page for some ideas on how to resolve.

http://www.google.com/support/forum/p/Chrome/thread?tid=25d7bc63a062da5b&hl=en

02/03/2012

Could you look in the server logs if there are some ERROR messages?
02/04/2012

Thank you for responding. I should have mentioned that it's not only Google Chrome that throws an error, Firefox gives a similar error (The page isn't redirecting properly) and Internet Explorer just keeps loading until it times out. Other browsers, other operating systems, other networks… it doesn't matter. As for the error logs. In the /var/log/nuxeo directory there are serveral log files, the server.log file was huge. It had grown to over 1 GB in size!

To analyse the situation, I stopped nuxeo, cleared the logs and restarted Nuxeo. After that I tried logging in again and the resulting server.log-file can be seen here:

http://www.xplicare.com/NI/nuxeo-4feb2012-server.log

Any thoughts?

02/04/2012



ERROR: language “plpgsql” does not exist

You did not properly initialized your PostgreSQL database. See Configuring PostgreSQL.

2 votes



Thank you Julien,

apparently I missed that part of the PostgreSQL configuration guide. Nuxeo works now! The new server-log (sample at http://www.xplicare.com/NI/nuxeo-6feb2012-server.log) is much smaller than before. There are a few warnings like 'no permission store available', but is it correct that this warning can be ignored?

02/06/2012

Those warnings can be ignored.
02/06/2012


Check your databases (postgres and repo) something is missing

0 votes