Configure Nuxeo ElasticSearch to use Amazon Elasticsearch

From what In understand, connecting a Nuxeo server to AWS Elasticsearch should work. I've configured the Nuxeo server to use the AWS service, and it works for the most part. However, I can no longer get the Admin Analytics page to load.

I set two variables in the nuxeo.conf to make it work, which I found those under this bug report:

  • elasticsearch.addressList=[[VPC endpoint]]
  • elasticsearch.client=RestClient

This is literally the only documentation I have seen on this, and so have no idea if I have done things properly, or if it's incorrect.

The error I get is repeated stack traces for this:

2018-03-27 16:25:12,898 ERROR [https-jsse-nio-] [] org.apache.http.conn.HttpHostConnectException: Connect to localhost:9200 [localhost/] failed: Connection refused (Connection refused)

Is there something I'm missing? Has anyone else tried this, or maybe there's a Nuxeo developer that can tell me if I'm on the right track?


1 votes

1 answers



I had the same error but on docker. I started a Nuxeo Server with following configuration in the docker-compose :

      NUXEO_DB_NAME: nuxeo
      NUXEO_DB_USER: nuxeo
      NUXEO_DB_PASSWORD: password
      NUXEO_ES_INDEX_NAME: nuxeo

I have this error when I try to access to the admin views based on ES. Otherwise, the indexation works. (My Nuxeo version is 10.10)

I saw that in the nuxeo.conf :

## Display Elasticsearch cluster and nodes information in admin center
## default is false (always true for embedded mode)

Does it mean that we have to set that variable to true ? Why we shouldn't do that ?

Anyway if this is the case the error is not really explicit. You should hide ES panels.


Hi, The documentation to setup Elasticsearch is here:

You have different ways to connect to Elasticsearch but when you use AWS Elasticsearch only the Rest protocol is available.

The configuration of the 2 options are documented on the same page.

About the Admin Analytic page, it uses the Elasticsearch passthrough feature:

This requires to configure the elasticsearch.httpReadOnly.baseUrl option to match your elasticsearch endpoint.

Note that you can find any nuxeo.conf option like elasticsearch.adminCenter.displayClusterInfo here:

Thanks to Nuxeo doc days, I will try to improve the documentation so the Elasticsearch Setup page also covers the passthrough option.

Regards ben

2 votes

Thank you ben :)