how to update libraries in Nuxeo IDE, so that the server will update its sources as well?

Hi,

I developed some jar library, and put it as user library in Nuxeo IDE.

Now, when I update my library, and replace the previous one, the changes are not taken into account by the server (even though I restarted it).

What should I do to force Nuxeo to take the new library into account?

Thanks,

Patrick

0 votes

2 answers

739 views

ANSWER

Did you :

  • define the library in Eclipse preferences > Nuxeo > User Libraries
  • add the library in the deployment Configurations
  • try to refresh in the Nuxeo Studio Panel
  • refresh in the Nuxeo Server panel ?
06/14/2013

Hi,

I did all of these, and even more:

I removed the nuxeo.war directory
I ran "mvn clean" in my project directory
I made sure that the jar file contained the modifications
I checked that the version in the bin directory in my package was updated

… any other idea??

Tx

Patrick

06/14/2013



It may be only for openJdk (I'm on linux), as apparently there is no cache for libraries with the jdk from Oracle.

I started this morning, and the new version was automatically taken into account. So maybe jar are refreshed every day.

Something else that seemed to work was to refresh the folder in eclipse, but I have to try it out again.

0 votes



So you have to reinstall your Eclipse :D

More seriously. A 3rd part library is considered as immutable and is put in static classloader. If you want reload it you can try to remove it from the preferences and add it again and restart the server.

But you can try also to just add the nuxeo nature on your project :

  • right click on the project > Nuxeo > Add Nuxeo nature
  • Add it into your deployment definition

It should hot reloads your project. But a next version of Nuxeo IDE should break this.

0 votes



I stopped, removed the library from the user preferences, started the server (with errors). Put the library back in the user preferences. Restarted … it still uses the old library!
06/17/2013

I even tried to give a new name to the library … without sucess!
06/17/2013

Did you try to reinstall your sdk ?
06/17/2013

Yes, I tried … but even that was not enough.

According to what you said about the class loading, I shut down my computer and started it again (to start with a new JVM). There was a change for better, but still some methods were not updated.

06/17/2013

Really strange.
06/18/2013