How to add a third party jar, to have it used at runtime in a nuxeo ide web-engine project ?

Hi, I'd like to know how to add a third party jar to a web engine project in nuxeo studio in order to have it found at runtime. I' done the tutorial for the webengine project and everythin was running fine. Then I wanted to add a third party jar (jsoup). My code compile in nuxeo ide, but when I launch the server and call my test url, i got a NoClassDefFound. I've added the jar in my user library as explained here : http://doc.nuxeo.com/display/IDEDOC/Managing+Project+Dependencies?src=search and when I saw it was not found, I've added the dependency in the pom.xml (see provided screenshot).

But the class is still not found after a stop / start of the server. I've also tried to create a lib directory at the root of my project and add this internal jar to User Library, but still no success to have it found at runtime.

Thansk in advance for your help,

Best regards,

David alt text

0 votes

1 answers

808 views

ANSWER



I've resolved my question, for all the other who will have the same problem : You need to edit the deployement configuration (there is a button for that in the nuxeo server view) and check your libraries.alt text

0 votes