When will LibreOffice be supported for Live Edit?

I tried the OpenOffice “Live Edit” plugin, but it caused LibreOffice 3.3.4 to hang. I'm running Linux Mint 11 (64-bit).

2 votes

3 answers

1381 views

ANSWER

I am experiencing pretty much the exact same issue.
04/02/2012



I WAS having the same issue (until 5 mins ago). Try adding a slash after /tmp -> /tmp/

Go and figure.

0 votes



First,

then, in the firefox plugin configuration page :

  • change the path to the temp folder ( usually /tmp/).
  • Add the default mapping for openoffice and modify each path (Editor command) with /usr/bin/libreoffice instead of /usr/bin/soffice.
  • check preserve compatibilty

that's all

1 votes



Thank you, but see this screenshot: alt text
12/05/2011


Did you follow this documentation: http://doc.nuxeo.com/x/vgQz

I recommend to check this following section “Setup Firefox protocol handler for OpenOffice.org”. You replace the Editor command value given for windows by ones for Linux, something like:

/usr/bin/libreoffice
0 votes



Still doesn't work. Same errors as in screenshot above. I'm running LiveEdit Protocol Handler 0.5.2, with configuration as shown in this screenshot: alt text
02/07/2012

can you check that libreoffice-java-common is installed on your computer.
02/07/2012

Yes, libreoffice-java-common is installed (version 3.4.5). Also, I am running Firefox 10.0 under Linux Mint 12.
02/07/2012

i m running the exact same configuration under ubuntu 11.10 64 ( very similar to mint).

for exemple - this is the first line of my configuration: Mime-type : application/vnd.oasis.opendocument.text Editor command : /usr/bin/libreoffice editor command arguments : macro:///LiveEditOOo.launcher.load(%s)

and my java version java -version : java version "1.6.0_23" OpenJDK Runtime Environment (IcedTea6 1.11pre) (6b23~pre11-0ubuntu1.11.10.1) OpenJDK 64-Bit Server VM (build 20.0-b11, mixed mode)

i don't have any clue on this problem, maybe you should try to purge libreoffice, erase the configurations folders, and get a fresh install

02/08/2012

Any update ?
03/19/2012