Live Edit Link column on Nuxeo Studio not show icon

When I customize the Nuxeo 5.5 using Nuxeo Studio, the default column for Live Edit Link doesn't show the icons link on the document listing page. If i remove the customized plugin then the Live Edit Link is there again. So I think there is something missing for that column or some option is not properly configured.

In our case we are using the org.nuxeo.ecm.platform.liveedit.config parameter set to server

0 votes

2 answers




When you edit the widget properties from Studio, there is a question mark beside the widget type. On the live edit link widget, it gives you more information about it :

This widget type displays a live edit link.

It requires the following fields configuration:

first field mapping the document model to be used for live edit link It also requires the following properties configuration:

file_schema: the file schema name file_field_name: the file field name filename_field_name: the file name field namefield name

Here are default properties used in Nuxeo that you need to add in you widget configuration.

  <property name="file_schema">file</property>

  <property name="file_field_name">content</property>

  <property name="filename_field_name">filename</property>

Redeploy and it should work this time :)

1 votes


Did you try to add the “live edit link” widget in the result layout of the “DefaultContentListingInNavigation” (I guess you are using the default template). To check that you did you can go to : Listing And Views > ContentViews > DefaultContentListingInNavigation and then on the result tab, you can add the live edit link widget from the left


0 votes

Thanks Fred, that's how i'm configuring it. Maybe there are missing options, we have tried on 2 different servers (32 and 64 bit) same results (no icons on the column inside the listings view), The live edit actually works when you open the individual document view. I'm not sure if it is related to this problem: