How to debug Live Edit plugins for Firefox and OpenOffice/MS Office ?

I work with DM 5.4.2 - HF13

Currently, I experience a lot of problems with the LiveEdit plugins. I installed:

  • Visual Studio 2005 tools for Office
  • Nuxeo Live Edit Minimal Installer
  • Nuxeo LiveEdit Protocol Handler (for Firefox) - along with the mappings for OpenOffice and MS Office
  • Live Edit for OpenOffice.org

For example, when I click the “Edit online” icon (on the “Summary” tab page of a document), nothing happens in Firefox (not for OpenOffice or Office documents). Same thing when I choose “Open in New Tab”: just an empty page is shown.

As an alternative, I navigated to the “Edit” tab page of the document and clicked on the link next to “Content: Keep” (the radio box). Then, OpenOffice or MS Office is opened.

In MS Office: when I click “Save in Nuxeo” (on the “Add-Ins” ribbon), the application asks to “Save in Nuxeo”. If I click “Yes”, the following error message is shown: “Couldn't save xxx.docx in nuxeo, the current document may have not been loaded by Nuxeo Live Edit”.

In OpenOffice: I click “Save in Nuxeo” in the Nuxeo menu. The following error occurs: “BASIC runtime error. An exception occurred. Type: com.sun.star.task.ErrorCodeIOException Message: .” and the program debugger points to:

sub store()

ThisComponent.store

End sub

in [My Macros & Dialogs].LiveEditOOo

I can't find any problems in the “server.log” file and I navigated to the Nuxeo program (LiveEdit) folder, but can't find any log files neither there. Where do I need to look and how can I solve my problems ?

Thanks in advance !

0 votes

6 answers

2174 views

ANSWER

Have you tried disabling all other Add-ins in the browser? I have seen conflicts between add-ins a number of times.
12/06/2011



Hi,

Into the LiveEdit plugin (Firefox) configuration, could you check if you have a correct and existing temporary folder.

After that, to have more informations with MS Office liveedit, you should check the log4net.xml file into your installation folder and look where there are written.

If logs are not enough, you may clone our mercurial repository (http://hg.nuxeo.org/desktop-integration/nuxeo-liveedit/) and use process attaching debugging (see msdn) and for instance, attach to Word process. But in your case, for MS Office, at save time LiveEdit is not able to find or read our descriptor file (filled with server information) (Connect.cs file, line 501 for more informations).

What Office version are you using? Did you made your tests with Internet Explorer too ? or only Firefox ?

2 votes



Just as an update to this issue:

  • Internet Explorer: I had to change registry keys to enable OpenOffice compatibility
  • Firefox:
    • the temporary working folder was not existing, LiveEdit doesn’t create one and thus just doesn’t do anything (no logging whatsoever) if the working folder doesn’t exist
    • the options of the LiveEdit protocol handler have to be handled this way (do this in the exact order !):
      • First remove all mappings
      • Then disable “Preserve compatibility” (I tried this first by changing the mappings manually in the Firefox configuration: see http://doc.nuxeo.com/pages/viewpage.action?pageId=4685857)
      • Then “Add default OpenOffice mapping”
      • Then “Add default MSOffice mapping”
    • it is claimed that the LiveEdit protocol handler is not compatible with Firefox 8 and 9, but it actually is; the drag and drop extension isn't
1 votes



Drag'n'drop plugin is deprecated with Firefox/Chrome from Nuxeo DM 5.4, it is handled by default with a HTML 5, Javascript combo.
12/28/2011


Hello,

About the “The HTTP header field “Accept”” message, this is because the live edit headers in the registry are not correct. You'll find how to correct them on this page: http://doc.nuxeo.com/x/IYBH.

Live Edit is not yet compatible with the latest versions of Firefox. We're working on it so Live Edit can support Firefox 8 and 9.

0 votes



So, can I assume now that Nuxeo is not compatible with Firefox 8.0 and Open Office 3.1 ?

0 votes



I am using Office 2007 on Windows XP.

The Internet Explorer version is working for MS Office. In IE, I don't get an “edit online” icon for OpenOffice documents though. When I look at the liveedit-msoffice-launcher.log, I only get loggings about the time I pressed the “Edit online” icon in IE; nothing about the many times I tried to get something with Firefox.

To make matters worse, I have seen now that in Firefox, the “Personal Dashboard” pages are empty. If I try to click “Add gadget”, I get the following message:

The HTTP header field “Accept” with value “text/html,application/xhtml+xml,application/xml;q=0.9,/;q=0.8,application/x-nuxeo-liveedit;application!msword;application!vnd.ms-excel;application!vnd.ms-powerpoint;application!vnd.openxmlformats-officedocument.presentationml.presentation;application!vnd.openxmlformats-officedocument.wordprocessingml.document;application!vnd.openxmlformats-officedocument.spreadsheetml.sheet” could not be parsed.

(take into account that I temporarily removed the OpenOffice mappings to check if they were causing the problems)

0 votes



You have, if I have a good memory, logs client side into $home/Local Settings/Application Data/Nuxeo.

0 votes