New 5.5 install not copying config to nuxeo.xml

I've been having trouble getting a new 5.5 install to connect to my PostgreSQL server and I tracked it down to the config parameters not being copied to nuxeo.xml. Any suggestions on what to do?

Using CentOS 6.2.

0 votes

3 answers

880 views

ANSWER



I got this solved.

Apparently, the xml file doesn't get updated with the postgresql settings if the database can't be reached. So this was a symptom, not the cause.

The cause turned out to be a simple firewall rule that was incorrect. In testing I had added rules to allow all traffic, but that wasn't sufficient. Once I completely disabled the firewall, nuxeo was able to connect to the database and everything worked great. Then we were able to recognize the bad rule.

0 votes



Thanks for the feedback, I'll try to reproduce in order to make the cause being properly detected and logged.
02/04/2012


I had a similar problem when I updated my template to 5.5. In the nuxeo.defaults file inside your template you must set the installation target according to the name of your template. For example, my custom template is called ima, so I have a setting in templates/ima/nuxeo.defaults which is ima.target=.

1 votes



You mean “not being copied to nuxeo.conf”. Try to manually edit the nuxeo.conf file.

0 votes



No, the nuxeo.conf file is correct, but the conf/Catalina/localhost/nuxeo.xml file is not being updated, at least it's not getting the PostgreSQL settings.
01/27/2012

Can you check in your nuxeo.conf that the nuxeo.force.generation parameter is not set to false?
01/27/2012

It is set to true.
01/27/2012

What about the nuxeo.templates parameter?
01/27/2012

nuxeo.templates=postgresql
01/27/2012

Can you check you have "postgresql.target=." in templates/postgresql/nuxeo.defaults?<br> If so, then run "./bin/nuxeoctl -d configure" and please post your "log/console.log" file (on some site such as http://friendpaste.com/).<br> Maybe post also the result of "tree".
01/27/2012

Console.log looks normal.

Nuxeo home: /nuxeo<br> Nuxeo configuration: /nuxeo/bin/nuxeo.conf<br> Log level set to DEBUG for: org.nuxeo<br> Include template: /nuxeo/templates/common<br> Include template: /nuxeo/templates/default<br> Include template: /nuxeo/templates/postgresql<br> Detected Tomcat server.<br> Configuration files generation (nuxeo.force.generation=true)…<br> Configuration files generated.

01/27/2012

That looks fine. <br> Since version 5.5, all datasources are now using the same JDBC resource which is not configured in nuxeo.xml but in the server.xml. Look at "Common datasource for all basic nuxeo datasources" in conf/server.xml. What is the configuration of the "jdbc/nuxeo" resource?<br> You didn't say if you checked the "postgresql.target" value (must equal ".") in templates/postgresql/nuxeo.defaults.
01/27/2012