Problem with Azure Storage configuration (DefaultBlobDispatcher)

Hi. Based on the documentation:, i'm triying to configure the DefaultBlobDispatcher for upload binaries to Azure based on a property.

With the following property it works fine:

  • dc:title=mytitle With the other too:
  • dc:title~myprefix

But now, I need upload binaries to Azure based on the property “path”, evenmore, the documentation says that:

“Each property name is a list of comma-separated clauses, with each clause consisting of a property, an operator and a value. The property can be a document property XPath, or ecm:repositoryName, or, to match the current blob being dispatched, blob:name, blob:mime-type, blob:encoding, blob:digest, blob:length or blob:xpath…”

But I'm triying with different options without good results:

  • ecm:path=/test/test/22
  • ecm:path=/test/*
  • ecm:path~/test/*

Any suggestion? Is correct the property “ecm:path”?

Thanks in advance.

0 votes

1 answers



Hi Florent! Thank you for your quick answer. This explain my test. Then … is wrong the documentation?

“The property can be a document property XPath, or ecm:repositoryName…”

Based on your answer… xpath neither ecm:respositoryName are valid…


The meaning for xpath is shifting depending on where it's used in Nuxeo, but in general it means the xpath of property backed by a standard, contributable schema. That's not the case for system properties.

ecm:path isn't considered a document property xpath, as it's not from a regular schema but a system property (ecm:). So it's not supported in the default blob dispatcher, you'll have to code your own subclass.

1 votes