Lost Studio hot reload on upgrade to v5.5

I've upgraded my project to nuxeo CAP/DM v5.5 on my CentOS release 5.7 (Final) system. I've registered the instance and now I've lost the hot upload functionality.

Upload works when the Admin Center->Update Center->Nuxeo Studio->Update button is pushed, but I need a manual restart of nuxeo for it to take effect.

The server.log file shows none of the normal “hot update” oriented tasks are being run.

I've tried de-registering and re-registering with no change: No automatic hot reload.

Any suggestions on where to look to find out what is happening?

0 votes

0 answers

676 views

ANSWER

Just to be sure to have all information, can you tell us if you at least see your typology deployed from your studio project or even the typology defined in it is not visible?

Can you give us your OS host

Can you activate the debug into your logs. I let you check how to do that here.

01/02/2012

Typology, if you mean document types create by me for this application, are visible but changes made in Studio are not visible until a reboot.

I turned on logging. I can see document type being unregistered and registered along with several other components being changed.

What should I be looking for in the logs?

01/03/2012

I'm sorry, I'm not sure of what you have.

If you

  • install a clean Nuxeo
  • register it with your connect account
  • download your studio bundles from Admin Center
  • Install it
  • go to your personal workspace
  • click on "new document" button
  • You don't see your new document types generated in studio ?
  • And if you stop the server and restart it, you can see it ?

Does I well understand ?

Sorry about logs, I give you a bad URL, here is the good one.

01/03/2012

I currently have a production image and development image running nuxeo DM v5.5 on separate hardware/db instances.

The production system, new since posting of this question, seems to update normally without a reboot. This is a fresh v5.5 image with a fresh database.

The development system seems to require a re-boot on only some Studio updates. I have yet to determine which changes to the configuration require a reboot of Nuxeo DB.

Sorry for the delay, I was working on other issues not related to Nuxeo.

01/18/2012

Thanks for the update :D
01/19/2012

More specifc info

It seem I only need to restart Nuxeo DM when I make changes to a Content View.

I worked for the most the a day on action chains and user actions and didn't need to restart when I did an update from Studio.

The first time I changed a content view and did a Studio update the changes would not take effect until I restarted.

01/20/2012

Update: It seems a restart of Nuxeo is necessary whenever I update the content views I've generated for my applications. The changes to the content views do not take place upon Studio update.
01/27/2012

Recently I noticed the loss of the "hot" update happens when changes are made to the content views. Changes to action chains and to document schemas/definitions, when updated using Studio, do not require a restart.
01/30/2012