After my Windows 2008 security update, my Nuxeo instance is stopped after 1mn

I experienced a really strange things since my windows 2008 has installed a Security Update.

  • I installed PostgreSQL 8.4.
  • I downloaded my Nuxeo 5.5 released from here.
  • I start the installer

All is Ok and work fine.

And Windows has decided to updated his security as he was feeling unsecured :)

  • After the restart I open the Nuxeo Console and click on the Start button.
  • The button is changed from “Start” to “Start in progress…”
  • After a while (one or 2 minutes) the server is stopped and the button comes back to “Start” instead “Stop”
0 votes

1 answers

1128 views

ANSWER



Dear Me,

After investigation I found 3 things that happened after your restart:

  • the postgres user used to start the postgres process is disabled

=> re-enable it

  • PostgreSQL installation is broken, each time I try to start the postgres service from the service console I have this message “ERROR 1503, …”

=> the only solution I found - as I'm not an expert - was to reinstall PostgreSQL. If you find a better solution, you're my guy.

  • a process from Windows is listening on 8005. If you don't trust me try a “telnet localhost 8005” - after a telnet installation, it's a bit long - and you will see. But I suspect this port affectation is random… so too bad for you, this port is used by tomcat for stopping it :)

=> the solution is easy: you modify the value nuxeo.server.tomcat-admin.port into nuxeo.conf to replace 8005 with a port not used (test it with telnet as you took time to install it).

For the last point, Nuxeo will improve the launcher to expose a better warn if the port is not available:

https://jira.nuxeo.com/browse/NXP-8192.

Have fun with your Windows.

1 votes



Don't modify server.xml directly as it will be overwritten by the templates, use the "nuxeo.server.tomcat-admin.port" parameter in nuxeo.conf.
12/19/2011

Thanks for me :)

I modified the answer.

12/19/2011